Contents

Before You Begin ...........................................................................................................................8

We’re Here to Help! .......................................................................................................................8

Video Tutorials ..........................................................................................................................8

SeqBuilder ......................................................................................................................................9

Overview ....................................................................................................................................9

10 Quick-Start Steps for Using SeqBuilder .............................................................................10

SeqBuilder Tutorials ................................................................................................................11

  Create a new feature .............................................................................................................11

  Display restriction enzyme sites ........................................................................................15

  Entering an Entrez sequence .................................................................................................16

  Displaying restriction sites based on frequency .................................................................17

  Displaying manually chosen restriction sites .....................................................................18

  Working with SeqBuilder cloning projects ........................................................................21

  Designing primers in SeqBuilder .......................................................................................35

Further Exploration ..................................................................................................................48

  Creating and removing panes and curtains ........................................................................48

  Searching the sequence ......................................................................................................48

  Using the nine SeqBuilder views .........................................................................................48

  Viewing and editing restriction site information ...............................................................50

  Exporting to GenVision .....................................................................................................50

SeqMan Pro ..................................................................................................................................51

Overview ..................................................................................................................................51

7 Steps for Using SeqMan Pro .................................................................................................52

SeqMan Tutorials .....................................................................................................................54
GeneQuest

Overview

10 Quick-Start Steps for Using GeneQuest

GeneQuest Tutorials

Opening an existing project and organizing methods
Applying methods to the sequence
Predicting coding regions and creating features
Corroborating predictions by BLAST search
Checking predictions against external data

Further Exploration

Additional analyses
Using the microscope view
Changing method parameters
Changing formatting options
Using method outlines
Exporting to GenVision

Protean

Overview

10 Quick-Start Steps for Using Protean

Protean Tutorials

Correlating annotations with predicted structures
Calculating methods with different parameters
Predicting proteolytic cleavage sites and performing SDS PAGE simulations

Further Exploration

Additional analyses
Using method outlines
Using the microscope view
Exporting to GenVision ...................................................................................................131

Protean 3D .........................................................................................................................132

Overview ..........................................................................................................................132

10 Quick-Start Steps for Using Protean 3D ...........................................................................132

Protean 3D Tutorials ..........................................................................................................133

Downloading a file from the Protein Data Bank .............................................................133

Using the Structure View .................................................................................................134

Changing the rendering of the structure .........................................................................136

Using the Sequence View ................................................................................................138

Selecting and hiding a structural component ...................................................................139

Recoloring a feature .........................................................................................................141

Working with a multi-model file .....................................................................................145

Further Exploration ..........................................................................................................148

PrimerSelect .........................................................................................................................149

Overview ..........................................................................................................................149

10 Quick-Start Steps for using PrimerSelect ........................................................................149

PrimerSelect Tutorials ...........................................................................................................150

Defining primer design criteria ........................................................................................150

Searching for primer pairs ..............................................................................................153

Viewing composition and hairpin reports .........................................................................155

Changing primer length ...................................................................................................156

Introducing a primer mutation .........................................................................................157

Creating a new primer ......................................................................................................158

Further Exploration ..........................................................................................................159

Sorting primers by characteristic .....................................................................................159

Selecting a primer pair .....................................................................................................159

Using only catalogued primers .........................................................................................159
Changing a text query ..................................................................................................................181
Searching text search query results .......................................................................................181

Working with Search Results Windows ......................................................................................181
Selecting one or more results ...................................................................................................182
Opening results in a Lasergene application .............................................................................183
Viewing results in a web browser .............................................................................................183
Saving multiple search results .................................................................................................184
Printing BLAST search results .................................................................................................184
Printing text search results ......................................................................................................185
Copying results ..........................................................................................................................185
Saving search results as text files .............................................................................................185

Copyright Information .....................................................................................................................186
Before You Begin

We’re Here to Help!

If you have any difficulties with or questions about these tutorials, please contact a DNASTAR support representative:

E-mail: support@dnastar.com
Phone (Madison, WI, USA): 608-258-7420
In the USA and Canada, call toll free: 1-866-511-5090
In the UK, call free on: 0-808-234-1643

Video Tutorials

In addition to these written tutorials, free video tutorials are available for many Lasergene applications. You can access the videos from the Training section of our website: http://www.dnastar.com/support/training.php.
SeqBuilder

Overview

SeqBuilder enables you to edit nucleic acid and amino acid sequences and view the sequences and related items in multiple ways. Available views include the following:

- Sequence view
- Feature List view
- Comment view
- Linear map
- Circular map
- Primer Design view
- Primer List view
- Minimap
- Site Summary

You can split SeqBuilder windows into multiple panes and view a sequence several ways simultaneously. Within a view, you can show or hide many meaningful display elements, including features, ORFs, translations, restriction sites, and comments.

SeqBuilder’s rich, high-quality graphical displays can be easily customized to suit your preferences. In addition, all graphical views can be copied and pasted into standard drawing programs, making the production of publication quality figures a simple task.

SeqBuilder enables you to perform automated virtual cloning using several different cloning methods. SeqBuilder supports virtual restriction enzyme cloning as well as TA Cloning, Directional TOPO® Cloning, Gateway® Cloning and Gateway MultiSite Cloning. An extensive vector catalog to use for cloning is installed with your software, and custom vectors can easily be created and added to it.

SeqBuilder can assist you with designing primers for regions of interest on your sequence. Once a primer pair has been selected and modified as desired, SeqBuilder enables you to cut and clone the PCR insert into a vector using one of the cloning methods mentioned above.
SeqBuilder uses dynamic links between the sequence and its annotations to automatically update feature coordinates as you edit a sequence. Additional functionality includes the ability to reverse complement, translate and back-translate sequences, identify ORFs and perform BLAST and Entrez text searches directly to NCBI.

SeqBuilder’s editing capabilities are integrated into most other Lasergene applications. SeqBuilder edits are shared automatically with other Lasergene applications that analyze the same data, making SeqBuilder an integral member of the powerful Lasergene Suite.

10 Quick-Start Steps for Using SeqBuilder

Here are ten basic steps for using SeqBuilder:

1) Create a new SeqBuilder project (FILE>New Project) or open an existing sequence file or project (FILE>Open).

2) Choose from among the nine views available for DNA sequences or from the three views available for protein sequences.

3) Modify the views by resizing, dividing, or closing panes and curtains, opening multiple views simultaneously, turning elements within the views on or off, rearranging elements on the display, or changing colors and styles of features so that they are easier to differentiate.

4) Select the restriction sites to display using the options in the Enzymes Displayed folder located in the curtain (DNA Sequences only). Or, setup new selectors (ENZYMES>New Selector) to define a group of restriction enzymes to display based on specific criteria.

5) Search the BLAST or Entrez databases for matches to your sequence or other interesting sequences using the options from the NET SEARCH menu.

6) Use the graphic results to form a hypothesis about your sequence, and then annotate any interesting features (FEATURES>New Feature).

7) Design primers for regions of interest on your sequence (PRIMING>Create Primer Pairs).

8) Use the options from the CLONING menu to perform automated virtual cloning with any of the following methods: restriction enzyme cloning, TA Cloning, Gateway® Cloning, or Directional TOPO® Cloning.

9) Open SeqBuilder files in another Lasergene application. Edits made in SeqBuilder, Protean, GeneQuest, PrimerSelect, or MegAlign will be shared universally between those programs.

10) Save this file (FILE>Save) and open another to begin again, or exit the program.
SeqBuilder Tutorials

The tutorials in this chapter should be followed in order, as they are designed to walk you through an example SeqBuilder project from start to finish. The Further Exploration section at the end of the chapter highlights optional features you may wish to use as you gain experience with the software.

Create a new feature

Objectives: To open a sequence file and then to create and modify annotated features in a sequence.

The data for this tutorial can be found in the following location:

- **Windows Vista®/Windows® 7**: C:\Users\Public\Public Documents\DNASTAR\Lasergene 9 Data\Demo Data
- **Windows® XP**: C:\Documents and Settings\All Users\Shared Documents\DNASTAR\Lasergene 9 Data\Demo Data
- **Macintosh OS® X**: Hard Drive:Applications:DNASTAR:Lasergene 9 Data:Demo Data

**Note:** You will be working with the same sequence for this tutorial and the next [Display restriction enzyme sites](#).

1) Launch SeqBuilder.
2) Select **FILE > Open**.
3) Select **pGEM-T Easy.seq** from the **Demo Data** folder. Click **Open**. The sequence appears as follows.
- The upper pane of the window contains the Sequence view. This view displays the base level DNA sequence. You can also display restriction sites, ORFs, and features in this view by using options from the curtain. For protein sequences, this view displays the ruler and protein sequence.

- The lower pane of the window contains the Feature List view. This view displays features that have previously been identified in the DNA or protein sequence. Features are annotations that provide additional information about a particular section of DNA or protein. Features may be user-defined, or they may be part of the input file from GenBank or from other Lasergene applications.

4) Select **EDIT > Go To Position**. The Go To Position dialog appears.
5) In the Position box, enter 10...128. Click OK. The region from base pair 10 to base pair 128 is now highlighted in the Sequence view, the Linear Map, and Circular Map views.

6) Select FEATURES > New Feature. A feature appears in the Sequence view in the top pane as an orange box and in the Feature List view as a new line entry, as shown below.

7) A blue box outlining the feature (the orange box) indicates that the feature has been selected. If you do not see a blue box, double-click the new feature to select it.

8) Select FEATURES > Edit Feature Style. The Feature Style panel appears.
9) On the Feature Style panel: from the Shape list, select **Filled Arrow**; uncheck **Shadow**. The Feature Style panel should appear as follows:

![Feature Style panel](image)

10) Click **Apply**, and then click **OK**.

11) In the Feature List view, click to the right of the equal sign next to the word `/note` on the new feature. Type **MCR** for multiple cloning region and press **Enter/Return**; this notation will now appear as the label for the feature in the Sequence view, as shown below.

![Sequence view](image)

12) To make this the permanent label for the feature, select **FEATURES > Use As Feature Label**.

Proceed to the next tutorial.
Display restriction enzyme sites

Objective: To display restriction enzyme sites in a sequence.

Note: Before beginning this tutorial, you should complete the previous tutorial (Create a new feature).

1) Click in the upper pane (Sequence view) to make it the active pane.

2) Locate the EcoRI enzyme by using the following technique.
   a) Next to the Enzymes Displayed folder in the upper pane’s curtain, click ⌉ (Mac) or ⊕ (Win) to expand the folder. You can now see the Filter by Selectors and All Enzymes - Alphabetical folders under the Enzymes Displayed folder.
   b) Click ⌉ (Mac) or ⊕ (Win) next to the All Enzymes-Alphabetical folder to expand it.
   c) Navigate through the alphabetically named folders to find EcoRI.

3) Check the box next to the EcoRI enzyme to display it. Note that both of the EcoR1 sites fall within the feature defined in the previous tutorial, as shown below.
4) Click ▼ (Mac) or ☐ (Win) next to the **Enzymes Displayed** folder in the curtain to collapse the folder. Note that the selected enzyme EcoRI remains displayed in the Sequence view.

5) Go to **FILE>Close**. SeqBuilder will ask if you would like to save the file.

6) Click **No**.

**Entering an Entrez sequence**

**Objective**: To enter a histone DNA sequence from NCBI’s Entrez database.

---

**Note**: In order to complete this tutorial, your computer must be connected to the Internet.

1) Launch SeqBuilder if it is not already open.

2) Select **FILE > Open Entrez Sequence**. The Open Entrez dialog appears.

3) Under Enter Sequence ID or Locus Name, enter **X05543.1**.

4) In the list box under that field, select **Nucleotide**.

---

5) Click **OK**. A Save dialog appears.

6) Find a location to store the sequence and click **Save**. The sequence appears.

Proceed to the next tutorial.
Displaying restriction sites based on frequency

**Objective:** To create and apply a frequency selector that displays only enzymes that cut the sequence twice or less.

**Note:** Before beginning this tutorial, you should complete the previous tutorial, *Entering an Entrez sequence.*

1) Select **ENZYMES > New Selector…** The Enzyme Selector Manager appears.

   **Note:** New Selector is highlighted in the Selector list and the Name is **New Selector**.

2) In the Name box, type **Two cuts max**.

3) From the Type drop-down menu, select **Frequency**.

4) Overwrite the number 1 in the Max box with the number 2. Leave all other parameters at their default settings.

5) Click **OK** to create the new selector and return to the main view.

6) Locate the new selector in the upper pane’s curtain by clicking ▶️ (Mac) or ➡️ (Win) next to the **Enzymes Displayed** folder. You can now see the **Filter by Selectors** and **All Enzymes - Alphabetical** subfolders.

7) Click ▶️ (Mac) or ➡️ (Win) next to the **Filter by Selectors** folder to expand it.
8) Put a checkmark in the **box** next to the **Two cuts max** selector to view the restriction enzymes that will cut this sequence two times or less.

9) Click ▼ (Mac) or □ (Win) next to the **Enzymes Displayed** folder to collapse the hierarchy.

Proceed to the next tutorial.

**Displaying manually chosen restriction sites**

Many restriction sites remain. You can now set some more stringent criteria.

**Note:** Before beginning this tutorial, you should complete the previous tutorial (Displaying restriction sites based on frequency).

**Objective:** To use one of the remaining sites to excise the histone-coding region from the X05543.1 sequence.

1) In the upper pane’s curtain, select **Minimap**.

<table>
<thead>
<tr>
<th>Name</th>
<th>Freq</th>
<th>100</th>
<th>200</th>
<th>300</th>
<th>400</th>
<th>500</th>
<th>600</th>
<th>700</th>
<th>800</th>
</tr>
</thead>
<tbody>
<tr>
<td>Acc65I</td>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>AauI</td>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>AcmI</td>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>AspCNI</td>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>BstYI</td>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>BxfI</td>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>BclI</td>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>BglII</td>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>BglII*</td>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>BsmBI</td>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>BglII</td>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The Minimap view displays a smaller version of the current DNA sequence. The Minimap is scaled to show the whole sequence in a single line. In this view, restrictions enzyme names appear as individual rows in the left-hand column. Their corresponding cut sites are shown in the same row on the right.
2) In the Feature List view (the lower pane), scroll up and/or down until you see the **CDS** feature for **Histone H2B-1** named **AA 1-122**. This is a sequence feature that was annotated in the original GenBank entry. The information for the feature was imported with the sequence when you opened it.

3) Double-click the feature to highlight the range defined by the feature in the Minimap view.

4) At the top of the Minimap view, click on the ruler. This will sort the enzymes in order of those with cuts closest to the selection, in this case, the CDS feature.

   ![Minimap View]

   **Note:** The restriction sites are sorted so that those cutting closest to and outside the feature appear near the top, those cutting further away from the outside appear further down, and those cutting inside the feature’s range appear at the bottom.

5) Leaving the feature highlighted, scroll to the top of the window. Note that the ApoI restriction site cuts just to the left and right of the histone gene, as shown below, and thus may be used for excising the gene.

   ![Selection View]

6) Select **ENZYMES > New Selector**. The Enzyme Selector Manager appears.

7) In the Name field, enter **ApoI selector**.

8) In the Type box, select **Pick**.

9) In the Remaining Enzymes list, scroll down to and select **ApoI**.
10) Click <-. ApoI now appears in the Selected Enzymes list, as seen below.

11) Click OK.

12) Apply the new selector using the following technique.

- Next to the Enzymes Displayed folder in the upper pane’s curtain, click ▶ (Mac) or ➕ (Win) to expand the folder. You can now see the Filter by Selectors and All Enzymes - Alphabetical folders under the Enzymes Displayed folder.

- Click ▶ (Mac) or ➕ (Win) next to the Filter by Selectors folder to expand it.

- Uncheck the box next to Two cuts max to unselect it.

- Check the box next to the ApoI selector to display it. The Minimap view now shows only the ApoI restriction sites.

13) Select FILE > Close. SeqBuilder will ask if you would like to save the file.

14) Click No.

Note: The Enzyme Selectors that you created will be saved, and can be accessed later either from the curtain or by going to ENZYMES>Selector Manager.
Working with SeqBuilder cloning projects

In addition to restriction enzyme cloning, SeqBuilder supports these three following commonly used methods:

- Gateway® Cloning
- Directional TOPO® Cloning
- TA Cloning

Note: Restriction cloning and TA cloning methods are discussed further in the section Designing Primers in SeqBuilder.

Beginning a New Cloning Project

To start a new cloning project, select FILE > New Cloning Project:

This New Project window is initially named Untitled Cloning Project, but you can rename it when you select FILE > Save Project As. All cloning projects contain three folders: Inserts, Vectors, and Clones.

When you create a project, you can either select inserts before you start cloning or select them during the process. With vectors, however, it is best to move any custom vectors into the Vector Catalog prior to including them in a project. The reason is that all but the restriction cloning projects use the vectors listed in the Vector Catalog.
Here is an example of what the folder looks like after cloning a PCR fragment:

![Folder with cloned PCR fragment]

**Note:** As stated earlier, if you have custom vectors that you plan to use, you can either create them during the course of the project or you must import them into the Cloning Vector Catalog before you can use them in a project. To do this, see the information in the next two tutorials.

### Adding custom vectors to a project

**Objective:** To create a custom TA or Directional TOPO vector for use with your cloning project.

1) Launch SeqBuilder

2) Go to **FILE > New Cloning Project.** The Untitled Cloning Project window will be displayed.

3) Select **FILE > Open** and choose the file `N.thermophilus_his.sbd` from the Lasergene 9 Data\Demo Data folder.

4) Double-click on the **PAS/PAC sensor signal transduction** feature to highlight it.

5) Hold down the **Alt** (Windows) or **Option** (Mac) key and do one of the following:

   - **To create a T-Vector:** Click and hold on the **CLONING** menu, then select **Create TA Cloning Insert** to add the linearized T-vector to the front-most project.

   Or

   - **To create a Directional TOPO vector:** Click and hold on the **CLONING** menu, and then select **Create Directional TOPO Insert** to add the linearized TOPO vector to the project.
Holding down the Alt/Opt (Win/Mac) key while selecting one of the menu options listed above changes the function of the menu item and acts as a shortcut for automatically creating linearized vectors with suitable overhangs. A linearized T-vector contains 3’ T overhangs at both ends. A linearized TOPO® Vector contains a 5’ GTGG overhang and a blunt 3’ end. Custom vectors without the appropriate overhangs will not be recognized in the Directional TOPO® or TA Cloning Advisors.

**Note:** If you create a linearized custom vector manually (without using the shortcut), you will likely also need to manually adjust the overhangs (CLONING>Change Overhangs) to meet the requirements listed above.

**Adding vectors to the Cloning Vector catalog**

The vectors listed in the Gateway® Cloning, Directional TOPO® Cloning, and TA Cloning advisors come from both your project and the CloningVectors.sbp catalog. To make your custom vector files available to the cloning advisors in all projects, you will need to add them to this special catalog. Otherwise, you will only be able to access your vector in the project(s) that contain it.

**Objective:** To add a vector to the Cloning Vector catalog.

The data for this tutorial can be found in the following location:

- **Windows Vista/Windows 7:** C:\Users\Public\Public Documents\DNASTAR\Lasergene 9 Data
- **Windows XP:** C:\Documents and Settings\All Users\Shared Documents\DNASTAR\Lasergene 9 Data
- **Macintosh OSX:** Hard Drive:Applications:DNASTAR:Lasergene 9

1) Launch SeqBuilder

2) Select **FILE > Open** to display the Open File dialog.

3) Highlight and double-click the **CloningVectors.sbp** from the location listed above. Cloning Vectors.sbp is the vectors catalog and is a cloning project.
4) Do **one** of the following:

- If the vector file is a sequence file, click on one of the folders, select **FILE > Import Sequences(s) to Project** to navigate to the file you want, and then double-click the sequence to open.

- If the vector file is a sequence file, open the file, select **FILE > Add ‘x’.seq to CloningVectors.sbp**. A copy of the sequence file is added to the project file.

- If the vector file is in another project file, open that project by selecting **FILE > Open**, change the Files of Type to a SeqBuilder project (.sbp) and select your project. Copy and paste the file from the project to the Cloning Vector catalog.

**Creating a Gateway® clone**

Gateway® Cloning is a widely used molecular technique that allows one to transfer DNA inserts between different cloning vectors while maintaining the reading frame and orientation of the insert. This technology eliminates the need for restriction enzyme digestion, ligation and colony screening for recombinants and is based on the site-specific recombination system of phage I.

**Objective**: To create a virtual Gateway clone.

The data for this tutorial can be found in the following location:

- **Windows Vista/Windows 7**: C:\Users\Public\Public Documents\DNASTAR\Lasergene 9 Data\Demo Data
- **Windows XP**: C:\Documents and Settings\All Users\Shared Documents\DNASTAR\Lasergene 9 Data\Demo Data
- **Macintosh OSX**: Hard Drive:Applications:DNASTAR:Lasergene 9 Data:Demo Data

1) Launch SeqBuilder

2) Select **FILE > New Cloning Project**. The Untitled Cloning Project window appears.

3) Add a sequence to the **Inserts** folder by first highlighting the folder.

4) Select **FILE > Import Sequence(s) to Project** to display the Open File window. Look for the Tn5wPCR.sbd sequence in the **Demo Data** folder, and double-click the file to add the file to the **Inserts** folder.
5) Open and select the insert sequence of interest. For this tutorial, click on the neomycin/kanamycin resistance feature labeled **aminoglycoside-3’-O-phosphotransferase** to select that range of sequence.

![Sequence Diagram]

6) Select **CLONING > Create Gateway® Insert/Entry clone**. The Create Gateway® Entry Clone dialog appears.
7) Choose your donor vector from pull down list (use PDONR™201), then click Create to add an Entry clone to your cloning project.

![Circular Map view](image)

**Note:** Features in the Circular Map view can be moved by double-clicking a feature and then dragging it either up or down.

8) Go to WINDOW>Untitled Cloning Project 1 to return to the project window.

9) Go to the Clones folder, select Untitled Entry Clone and go to EDIT>Rename. Rename the sequence GA clone1.
10) Select **CLONING > Gateway® Cloning Advisor**. The advisor dialog appears.

![Gateway® Cloning Advisor](image)

11) Select a suitable entry clone, (use **GA clone1**), and destination vector (use **pAd/BLOCK-iT™-DEST**) for recombination, then click **Recombine**.

![Selection](image)

12) Save the project and the information in its subfolders by selecting **FILE>Save Project As**.

13) Enter a new name in the File Name field and choose a file location, then click **Save**.

14) Go to **FILE>Close**.
Creating a Gateway® MultiSite clone

Multisite Gateway® technology enhances the classic Gateway® cloning protocol by allowing you to clone up to four regions at one time. In Multisite Gateway cloning, three additional types of recombination sites have been engineered to recombine uniquely between the two ends of a source sequence and a host vector.

Objective: To create a clone that has a Pol promoter, two multiple cloning sites, and a reporter gene.

The data for this tutorial can be found in the following location:

- **Windows Vista/Windows 7:** C:\Users\Public\Documents\DNASTAR\Lasergene 9 Data\Demo Data
- **Windows XP:** C:\Documents and Settings\All Users\Shared Documents\DNASTAR\Lasergene 9 Data\Demo Data
- **Macintosh OSX:** Hard Drive:Applications:DNASTAR:Lasergene 9 Data:Demo Data

1) Launch SeqBuilder

2) Select **FILE>Open**. Navigate to the **Demo Data** folder, select the **MultiSiteExample.sbp** file, and click **Open**. The MultiSite Example cloning project is displayed.

3) Expand the **Inserts** folder so that the project appears as follows:

![MultiSiteExample.sbp](image)

4) To set up the entry clone for Green Fluorescent Protein, the reporter gene, open the **GFP** sequence by double-clicking on it. The GFP sequence is displayed in the Sequence View.

5) Select **EDIT>Select All** to select the entire GFP sequence.
6) Then, select **CLONING>**Create Gateway® Insert/Entry Clone. The Create Gateway® Entry Clone dialog appears.

![Create Gateway® Entry Clone dialog](image)

7) In order to place the GFP reporter gene into the last of the four insert positions, we need to select the donor vector with the appropriately annotated P3-P2 att sites. Select **pDONR221-P3P2** from the dropdown list, and then click **Create**. An entry clone will be created and displayed containing the GFP insert, and automatically added to your project in the **Clones** folder.

8) Close the newly created Untitled Entry Clone, and then select it from the Project Window. Rename it to **GFP L3-L2** by selecting **EDIT>**Rename.
9) Repeat steps 4-8 for the other 3 insert sequences.

- For BlueScriptMCS, select pDONR221-P5P4 for the Donor Vector and rename the newly created clone BlueScriptMCS L5-L4.

- For pGemMCS, select pDONR221-P4rP3r for the Donor Vector and rename the newly created clone pGemMCS L4-L3.

- For polh, select pDONR221-P1P5r for the Donor Vector and rename the newly created clone polh L1-L5.

10) Once all the entry clones are constructed, we are ready to perform the final recombination. Expand the Vectors folder from the Project Window, and select the destination vector pYES-DEST52.
11) Select **CLONING>Gateway® Multisite Cloning Advisor**. The Gateway MultiSite Cloning Advisor is displayed and lists the destination vector we had selected from the Project Window:

![Gateway MultiSite Cloning Advisor](image)

12) Notice in the Experiment Analysis section of the dialog, the Advisor lets us know that we need to specify entry clones before recombination can occur. To do this, go back to the Project Window, and click on the **Clones** folder to select it. Then, drag and drop the **Clones** folder onto the **Gateway MultiSite Cloning Advisor** window. All of the newly created entry clones from the **Clones** folder will be added to the Advisor window:

![Gateway MultiSite Cloning Advisor](image)
13) Notice that in the Experiment Analysis section of the window, a message appears to let us know that recombination of the specified plasmids will result in one clone with four inserts. Since this is the result we expect, click the **Recombine** button to proceed with recombination. The expression clone containing all four inserts is created and displayed in the Circular Map view:
Creating a Directional TOPO® clone

Directional TOPO Cloning utilizes DNA topoisomerase I, which allows researchers the ability to directionally clone DNA targets. The enzyme functions as both a restriction enzyme and ligase. The covalent attachment of DNA topoisomerase I to the vector allows researchers the ability to directionally clone targets with a high degree of specificity.

Objective: To create a TOPO clone.

The data for this tutorial can be found in the following location:

- **Windows Vista/Windows 7**: C:\Users\Public\Public Documents\DNASTAR\Lasergene 9 Data\Demo Data
- **Windows XP**: C:\Documents and Settings\All Users\Shared Documents\DNASTAR\Lasergene 9 Data\Demo Data
- **Macintosh OSX**: Hard Drive:Applications:DNASTAR:Lasergene 9 Data:Demo Data

1) Launch SeqBuilder

2) Select **FILE>New Cloning Project**. The Untitled Cloning Project window appears.

3) Add a sequence to the **Inserts** folder by first highlighting the folder.

4) Select **FILE > Import Sequence(s) to Project** to display the Open File window. Look for the **Tn5wPCR.sbd** sequence in the **Demo Data** folder, and double-click the file to add the file to the Inserts folder.

5) Open the insert sequence, and select the sequence range of interest. For this tutorial, click on the neomycin/kanamycin resistance feature labeled **aminoglycoside-3'-O-phosphotransferase** to select that range of sequence.
6) Select **CLONING > Create Directional TOPO Insert**. The new insert is placed in the Inserts folder, and the Directional TOPO Cloning Advisor dialog is displayed.

![Directional TOPO Cloning Advisor](image)

7) Verify the selected insert, and choose the appropriate cloning vector (use **pBAD102/D-TOPO®** for this tutorial). Click **Clone**. The clone is displayed in a new window and it is stored in the Clone folder of the project window.

**Note:** The TOPO vector sequence should be linearized at the appropriate base pair prior to adding to the cloning project. See **Adding custom cloning vectors to a project**.

8) Click **Circular Map** in the View pane then click the **Features Displayed** checkbox within the curtain.
Note: Features in the Circular Map view can be moved by double-clicking a feature and then dragging it either up or down.

9) Save the project and the information in its subfolders by selecting FILE>Save Project As.

10) Enter a new name in the File Name field and choose a file location, then click Save.

**Designing primers in SeqBuilder**

SeqBuilder enables you to design primers for regions of interest on your sequence. If desired, once a primer pair is selected and modified, SeqBuilder allows you to cut and clone the PCR insert (with corresponding primer features) into a vector.

The data for the tutorials in this section can be found in the following location:

- **Windows Vista/Windows 7**: C:\Users\Public\Public Documents\DNASTAR\Lasergene 9 Data\Demo Data
- **Windows XP**: C:\Documents and Settings\All Users\Shared Documents\DNASTAR\Lasergene 9 Data\Demo Data
- **Macintosh OSX**: Hard Drive:Applications:DNASTAR:Lasergene 9 :Demo Data
Creating and modifying primer pairs for a region of interest

Objective: To create a primer pair for a region of interest on your sequence.

1) Launch SeqBuilder.

2) Select FILE>Open and choose Tn5wPCR.sbd from the Demo Data folder. The sequence opens in the Linear Map view.

3) Choose the neomycin/kanamycin resistance feature labeled aminoglycoside-3'-O-phosphotransferase as the region of interest by single clicking on that feature. The sequence range 1559-2353 will be selected.

4) Select PRIMING>Create Primer Pairs. The Create Primer Pairs dialog appears.

5) Click the triangles next to Conditions and Primer Characteristics to expand those sections.

Note: The Locations section of the Create Primer Pairs dialog allows you to specify parameters that define where SeqBuilder will search for primers on your sequence. The Conditions section allows you to specify the initial salt concentration, which affects the calculation of predicted melting temperature. The Primer Characteristics section enables you to limit your search for primers based on primer length, target melting temperature, and primer interactions at the 3’ end. You also have the option in this dialog to avoid known repetitive sequences that are likely to cause mispriming.
6) Adjust the **Target Tm** to **55.0°C**. Leave the rest of the values as they are, and then click **OK**.

SeqBuilder will choose the best primer pair with the characteristics specified that lies exactly within the selected region and display it in the Primer Design View. By default, the view focuses on the top strand primer first.

**Note:** While the default settings are useful in most cases, we have deliberately chosen an example in which the default **Primer length** values will not yield optimal results.
7) If necessary, resize the Primer Design View pane by clicking and dragging the dividing bar between panes so that you can see all 3 sections of the view: the Residue Pane, the Mispriming Pane, and the Alternate Pairs Pane:

![Primer Design View](image)

**Note:** If desired, you can choose to display the Primer Design View in both the top and bottom panes, and then scroll to the Mispriming and Alternates Pairs sections in the bottom pane so that you can easily see all three sections at once. As you edit the primer in the Residue Pane, the other two panes are automatically updated to reflect the changes.

8) Notice in the Mispriming Pane, the **Most stable dimer** and **Most stable pair dimer** are both labeled “BAD!” This indicates that the final pentamer value of the dimer exceeds the 3’ **pentamer stability** threshold defined in the Primer Characteristics section of the Create Primer Pairs dialog. In general, you should avoid using primers with dimers or hairpins labeled “BAD!” unless you have experimental evidence that they will function as desired, or if you have no other option.

9) Switch to the Primer List view by selecting it from the curtain shown on the left side of the SeqBuilder screen. The single primer pair located by your search is displayed.
10) Click the triangle next to **Set 1** to expand the primer pair and view each individual primer within the pair:

<table>
<thead>
<tr>
<th>Set Name</th>
<th>Pair</th>
<th>T/B</th>
<th>Primer Sequence</th>
<th>Length</th>
<th>Tm</th>
<th>dG</th>
<th>Current</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Set 1</strong></td>
<td>Pair 1</td>
<td></td>
<td>&lt;ATGATGACAAGATGAGTTGAC&gt;, &lt;CCCTCTTGA&gt;</td>
<td>79</td>
<td>50.8</td>
<td>-30.6</td>
<td></td>
</tr>
<tr>
<td></td>
<td>T</td>
<td>A</td>
<td>ATGATGACAAGATGAGTTGAC</td>
<td>22</td>
<td>50.8</td>
<td>-30.6</td>
<td></td>
</tr>
<tr>
<td></td>
<td>B</td>
<td>A</td>
<td>TCATGAAATCTCCTACAAGAGG</td>
<td>22</td>
<td>50.5</td>
<td>-30.2</td>
<td></td>
</tr>
</tbody>
</table>

11) Notice that the melting temperatures for the individual primers are both close to 50°C, which is lower than our Target Tm of 55°C.

12) Switch back to the Primer Design view to view the top strand primer:

13) Select the codon change mode by clicking on the button in the Primer Design Toolbar. Notice that your cursor changes and that each codon is highlighted as you hover over the sequence.

14) Introduce a codon change by clicking on the TTG triplet in your primer, located at 1577-1579 of your sequence. From the list of codons given, select **CTA**. Notice that changes to the primer sequence and translation are shown in magenta, and that the Mispriming Pane has now updated to show that there is no longer a stable dimer conformation.

15) Display the bottom strand primer by clicking the button from the Primer Design Toolbar. The Primer Design View scrolls to show the bottom strand primer in the center of the view:
16) Increase the length of the bottom strand primer from 22 bp to 23 bp by clicking and dragging the triangle shown on the left (3’) end of the primer sequence. The length of the primer is displayed and updated automatically in the Primer Design Toolbar shown at the top of the view:

17) Notice that once the primer length is increased to 23 bp, the melting temperature for the bottom strand primer increased to 54.4°C, which is much closer to our Target Tm. Also notice that the Most stable pair dimer has been updated in the Mispriming Pane and no longer has the indication: “BAD!”.

18) Switch back to the top strand primer by clicking on the button. Increase the length of the top strand primer from 22 bp to 29 bp by clicking and dragging the triangle shown on the right (3’) end of the primer sequence. Notice that the melting temperature of the top strand primer has now increased to 55.0°C.

19) Now that the primers have been modified to our satisfaction, change back to the Primer List view by selecting it from the curtain on the left.

20) Expand the pair again by clicking on the triangle next to Set 1. Notice that the edits to our primer pair are reflected here as well. Nucleotide changes to the primer sequence are shown in lowercase.

21) Name the modified pair by clicking on Pair 1 in the Pair Name column and typing Modified pair.

Proceed to the next tutorial.
Creating a PCR insert for TA cloning

Now that the primer pair has been selected and modified as desired, you are ready to extract the PCR product for cloning.

Objective: To extract the PCR insert and create a virtual TA clone.

1) Choose PRIMING>Create Insert by PCR to extract the sequence of the PCR product and simulate its amplification with Taq polymerase including the addition of 3’ A overhangs to each end. SeqBuilder will automatically create a new cloning project and display the new Taq amplified insert within the Inserts folder:

![Untitled Cloning Project 1](image)

2) Select CLONING>TA Cloning Advisor to display the TA Cloning Advisor dialog:
3) Notice that your PCR amplified insert is already selected in the Insert field. Select pGEM®-T Linearized from the Linearized T-Vector dropdown list, and then click Clone. The clones, forward and reverse orientations, are created and displayed.

4) Bring the forward clone into focus by selecting WINDOW>Untitled TA Clone (forward orientation). Notice that the primers, PCR product, and reading frame are all displayed in the Sequence View as features. These features can also be seen in the Feature List view, as well as all graphical views.

5) If desired, save the project and the information in its subfolders by selecting FILE>Save Project As. Otherwise, choose FILE>Exit to close the project and exit SeqBuilder.

Note: To create a cloning insert from the PCR product of the current primer pair using a cloning method other than TA Cloning, simply select the range of sequence for the PCR product you wish to amplify, and then select the appropriate command from the CLONING menu, depending on the type of cloning you wish to do. For information on other cloning methods, see the section Working with SeqBuilder Cloning Projects.

Creating primer pairs and manually introducing restriction sites

Objective: To create primer pairs for a gene of interest, and then manually introduce restriction sites to prepare for restriction cloning.

1) Launch SeqBuilder.

2) Select FILE>Open and choose N.thermophilus_his.sbd from the Demo Data folder. The sequence opens in the Linear Map view.

3) Select the range of sequence for the CDS feature named PAS/PAC sensor signal transduction histidine kinase by single-clicking on it. Notice in the header that the range 10086-11369 is selected.

4) Select PRIMING>Create Primer Pairs. The Create Primer Pairs dialog appears.
5) Select the radio button next to **Choose optimal primer location** and leave the other values as they are. This will allow SeqBuilder to choose the best primer locations from within 50 bp of the surrounding sequence.

![Create Primer Pairs](image)

6) Click **OK**. SeqBuilder locates the best primer pair and displays the top strand primer in the Primer Design view.

7) The top strand primer is 24 bp in length. Extend the primer 8 bp by clicking and dragging the triangle shown to the left of the primer sequence. Notice that the length in the header now shows that the top strand primer is 32 bp in length.
8) Select the button from the Primer Design toolbar to enter into the mode for introducing restriction sites. Notice that your cursor changes to look like scissors.

9) Place your cursor to the immediate left (5' end) of the extended primer and click. From the resulting menu, select Any Enzyme, and then select the enzyme SacII. (Hint: To navigate quickly through the alphabetical list of enzymes, type “S” to skip directly to that letter in the list). The SacII enzyme is introduced.

![Enzyme List](image)

Note: Notice that the new restriction sites are displayed in magenta, as well as nucleotides in the primer sequence and their translations that differ from the template. Restriction enzymes whose recognition sites are eliminated by the change are shown in blue.

10) Click to display the bottom strand primer. Notice that the bottom strand primer is also 24 bp in length, as shown in the Primer Design toolbar.
11) Extend the bottom strand primer 6 bp to increase its length to 30 bp. Do this by clicking and dragging the triangle shown to the right of the primer sequence.

12) Select the button again, and click immediately to the right (3’ end) of the extended bottom strand primer sequence. Select **Any Enzyme**, and then select the enzyme **Ascl**. The **Ascl** enzyme is introduced into your sequence.

Proceed to the next tutorial.

**Creating a PCR insert for restriction cloning**

**Objective:** To extract the PCR insert and use restriction cloning to insert it into a Gateway® Entry clone.

Now that the appropriate restriction enzymes have been added to the sequence, we can cut and clone the histidine kinase gene into the desired vector.

1) Select **PRIMING>Create Insert by PCR**. A new cloning project is created and the PCR amplified insert appears in the **Inserts** folder.

**Note:** This menu item extracts the sequence of the PCR product and simulates its amplification with Taq polymerase including the addition of 3’ A overhangs to each end. In this example, we will use restriction cloning, which cleaves the sequence at the designated restriction sites. Thus, the 3’ A overhangs will not affect the resulting clone.

2) Select **FILE>Open** and choose the cloning vectors catalog, **CloningVectors.sbp**, from the **Lasergene 9 Data** folder.

3) In the Cloning Vector catalog, expand the **Gateway Vectors** folder, and then expand the **Entry Clones** folder.
4) Find pENTR™/D-TOPO® and move it into the Vectors folder within your cloning project, either by dragging and dropping, or by using the copy/paste options from the EDIT menu.

5) Open the PCR amplified insert from the Inserts folder by double-clicking on it. The sequence opens in the Sequence view.

6) Switch to the Linear Map view by selecting it from the curtain.

7) Display unique enzymes by expanding the Enzymes Displayed folder, then expanding Filter by Selectors and checking the box next to Unique Sites. A confirmation dialog may appear. Click Yes. All of the unique restriction enzymes will be displayed on your sequence.

8) Click on SacII on the far left (5’) end of the sequence. Then, Shift-click on Ascl on the far right (3’) end of the sequence. Notice in the header that the enzymes and the sequence between them are selected.

9) Select CLONING>Copy Restriction Insert. The insert is copied to the clipboard.

10) Return to the cloning project window by selecting WINDOW>Untitled Cloning Project 1.
11) Double-click on **pENTR™/D-TOPO®** from the **Vectors** folder. The sequence opens in the Circular Map view.

12) Select **EDIT>Go to Position** and type **669...704**. Click **OK**. The region between the two recombination sites, shown in orange, is selected.

13) Switch to the **Sequence** view by selecting it from the curtain. Notice that there are SacII and AscI sites spanning the TOPO® recognition sites.

![Restriction enzyme map](image)

14) Click on **SacII** and then Shift-click on **AscI**. The enzymes and the sequence between them are selected.

15) Select **CLONING>Clone Restriction Insert**. The Clone Insert dialog appears.

16) Since both ends are already compatible, click the **Clone** button. A new Untitled Clone is created and displayed. You now have a thermostable kinase within a Gateway® entry clone, ready to clone into a Destination Vector.

17) If desired, save the project and the information in its subfolders by selecting **FILE>Save Project As**. Otherwise, choose **FILE>Exit** to close the project and exit SeqBuilder.

For more information on Gateway Cloning, see the section **Working with SeqBuilder Cloning Projects**.
Further Exploration

Creating and removing panes and curtains

The default SeqBuilder document window contains two panes (one above the other). Each pane in turn contains a curtain on the left and a view on the right. Curtains contain options that provide rapid access to the most common elements that you may want to display in a given view. Views display data, as modified by the options selected in a curtain. By default, the upper pane displays the Sequence view and the lower pane displays the Feature List view for the same file. The SeqBuilder document window can be divided into any number of panes. Create a new pane by clicking and dragging the small box directly above a pane’s vertical scroll bar on the far right, by clicking and dragging the small box to the left of a pane’s horizontal scrollbar, or by using the Vertical Split or Horizontal Split options from the WINDOW menu. Remove a pane by double-clicking the divider between two panes or by dragging the divider between any two panes all the way to the divider of another pane.

Searching the sequence

To locate an ORF, a particular portion of sequence, or a specific restriction site or feature, select EDIT > Find. To find the next instance, click Find Next or select EDIT > Find Again.

Using the nine SeqBuilder views

The Views folder in a curtain permits you to choose from the following views by clicking the icon next to the view name or by clicking on the name. The options available in a curtain vary with the view selected. If a portion of a sequence is selected (highlighted) in one view, the Circular Map, Linear Map, Minimap, Sequence, and Primer Design view in another pane will likewise display the same highlighting.

Views available for both nucleotide and protein sequences

Sequence: Click to display the base level DNA sequence. By default, this view also shows translations and ORFs. You can also display restriction sites, partial translations, and features in this view by using options from the curtain. For protein sequences, this view displays the ruler and protein sequence. This view is in the upper pane in the initial default setting.

Feature List: Click to display features that have previously been identified in the DNA or protein sequence. Features are annotations that provide additional information about a particular
section of DNA or protein. Features may be user-defined, or they may be part of the input file from GenBank or from other Lasergene applications. By default, this view is in the lower pane.

Comment: Click to display a comment that is associated with this DNA or protein sequence. Comments are optional and not all sequences have them. This is where the text of a Genbank entry appears. You may enter any free-form text that you wish in this view.

Views available for nucleotide sequences only

Linear Map: Click to display a linear map of the current DNA sequence. This view displays on one page by default, but you can change the number of pages by going to FILE>Page Layout. This view shows selected restriction sites, ORFs, and features along the linear map.

Primer Design: Click to design and analyze primers for your sequence. The Primer Design view is divided into 3 panes. The top pane displays the base level nucleotide sequence, restriction sites, translations, and features, as well as the currently selected primer sequence. The middle pane shows primer binding sites, and the most stable conformation of dimers, pair dimers, and hairpins, if they exist. The bottom pane displays the list of primer pairs discovered by your search, along with additional information for each pair, including product length, melting temperatures, and a quality score.

Primer List: Click to view the results from your primer searches. The Primer List displays the primer sequence, the length of the primer and the product (for primer pairs), melting temperature, dG values, and is formatted like a spreadsheet to allow for easy selection and sorting.

Circular Map: Click to display a circular map of the current DNA sequence. This view shows selected restriction enzymes and features. The Circular Map view is scaled to fit onto one printed page by default, but you can change the number of pages by going to FILE>Page Layout.

Minimap: Click to display a smaller version of the current DNA sequence. The Minimap is scaled to show the whole sequence in a single line. Each row in this view shows where a particular restriction site falls along the sequence.

Site Summary: Click to display a table of restriction sites and their locations on a DNA sequence. This view displays restriction sites that are selected in this pane or in another pane.
**Viewing and editing restriction site information**

- To view and edit restriction sites in the restriction enzyme library, select **ENZYMES > Enzyme Manager**.

- To add a new restriction enzyme to the library, select **ENZYMES > New Enzyme**.

**Exporting to GenVision**

- To export your SeqBuilder document as a **GenVision** project, select **FILE>Export as GenVision Project** from the Linear Map, Circular Map, Sequence View, or from the Project Window. (For protein sequences, this option is available from the Sequence view only).

- To create images in GenVision that compare the features from multiple sequences, first load and select the desired sequences into a **Project Window (FILE>New Project)**. Then, choose **FILE>Export as GenVision Project**. The resulting dialog finds matching features in the selected sequences and allows you to select which types of features to include in the export. One GenVision project will be created for each of your selected sequences, and will display the features from one sequence connecting to the same features in all of the other sequences where it occurs.
**SeqMan Pro**

**Overview**

SeqMan is both a sequence assembler for small to medium-sized projects, and a viewer for all assembly projects, including large BAM assemblies.

**Using SeqMan as a Viewer and Editor:**

SeqMan 9.0 allows you to view and edit traditional assemblies, including SeqMan projects, Phrap and Sequencher assemblies, but does not provide statistical calculation of their SNPs.

By contrast, SeqMan supports the viewing of BAM assemblies and the statistical calculation of their SNPs, but does not support editing of BAM assemblies.

Assembly information is summarized in SeqMan’s tabular reports and graphical views. The Strategy View graphically summarizes the position and orientation of every constituent sequence in a contig or contig scaffold, and allows you easily assess the coverage in your assembly. If coverage seems unsatisfactory, you can add more sequences and reassemble, or you can use the Primer Walking feature to drive the closure of gaps or to fill in low coverage areas. The Alignment View gives you a more detailed picture of the assembly, and allows you to edit constituent and consensus sequences, override the called consensus, review underlying trace or flowgram data, add new features, restore previously trimmed data, and adjust alignments. You may also evaluate putative SNPs identified by SeqMan, force contigs to join, or split a contig into two or more segments. Once you are satisfied with your assembly, you may save your project, export the data, or merge contigs with those imported from previous assembly projects.

**Using SeqMan as an Assembler:**

SeqMan enables you to assemble fragment data from sequencing projects up to tens of thousands of fragments. (Projects from tens of thousands of fragments up to human genome size can instead be assembled with DNASTAR’s SeqMan NGen 3.0). Sequences can be assembled from numerous *file formats*, including trace data from automated sequencers, and data output created using 454™ technology. SeqMan removes unreliable data, including poor quality ends, subminimal length reads, and vector and contamination host sequences in a single pass, then assembles the trimmed data and calls the consensus.

SeqMan provides two different assembly methods: the Classic assembler, and the Pro assembler. In general, the Pro assembler should be used when your data are: 1) large; 2) contains repeated sequences; 3) has noisy ends; or 4) is being used for SNP analysis. The
Classic assembler should be used when: 1) your data does not contain repeated sequences; 2) you do not use vector trimming; or 3) you want to reproduce an assembly made from a previous version of SeqMan. As with all SeqMan parameters, you may select one of these assemblers as your default assembly method. You may also switch between the Pro and Classic assemblers with each SeqMan project.

For projects that utilize trace data from automated sequencers, SeqMan includes DNASTAR’s unique Trace Quality Evaluation system. This system evaluates the quality of the underlying trace data, and then generates the most accurate consensus sequence possible. This method is so effective that it reduces the depth of coverage needed for accurate sequence determination, yielding spectacular savings in time and effort.

Before assembling the sequences, be sure to review SeqMan’s preassembly options. These options include trimming poor-quality data manually or automatically, removing specific vector or contaminant sequences, and identifying repetitive sequences so that they will be added last during assembly. You may also adjust a wide variety of parameters for the assembly process, including which assembly method is used, as mentioned above. Once you have selected the options you want, click the Assemble button to activate all of the trimming, assembly and consensus calling options you selected. If you prefer to assemble certain groups of sequences separately, use the Assemble in Groups option.

---

**7 Steps for Using SeqMan Pro**

1) Open an existing assembly or create a new SeqMan project.
   a) To open an existing SeqMan project or SeqMan NGen assembly, select **File>Open**.
   b) To open an existing Phrap or Sequencher assembly project, choose **File>Import**.
   c) To begin a new project, select **File>New**.
      i) Add sequences to the project by selecting **SEQUENCE>Add** or clicking on the Add Sequences button in the Unassembled Sequences window. Projects may utilize any combination of supported formats.
      ii) Review the **PROJECT > Parameters** and edit them, if desired.
iii) Use the buttons at the top of the Unassembled Sequences window to prepare sequences for assembly. Preassembly options include the removal of vector sequence(s), removal of contaminant sequence(s), identification of repetitive sequence(s), automated 5’ and 3’ end trimming, and manual end setting. Removal of vector sequence(s) is strongly recommended when using Sanger data. We also recommend that you accept the default preassembly option allowing SeqMan to optimize the order in which it assembles sequences. To perform the preassembly processes without assembling the data, click **Options**, and then click **Scan All**. Otherwise proceed to the next step.

iv) When you have selected all the preassembly options you want, click **Assemble** from the Unassembled Sequences window to begin the assembly. To assemble certain groups of sequences separately, use the **Assemble in Groups** option. Results will be displayed in both the Project Summary window (“Untitled.sqd”) and in a new Report window. The Project Summary window shows constituent sequences in the bottom pane and contigs in the upper pane.

2) Select **CONTIG > Alignment View** to examine detailed sequence alignments, traces, features, and individual consensus conflicts.

3) Select **FEATURES> Show Feature Table** to view and manage all of the features within your current project. If desired, add features to the consensus sequence by choosing **FEATURES>Copy Selected to Consensus**.

4) Select **CONTIG > Strategy View/Scaffold Strategy View** to obtain an overview of coverage, conflicts, paired end data consistency, and consensus features for each contig in your assembly.

5) You may also view **PROJECT > Statistics**, **PROJECT > Trim Reports**, **CONTIG>Coverage Report**, and **CONTIG > Contig Info** reports.

6) Utilize some of the many post-assembly options that SeqMan offers, including SNP discovery, primer walking, editing conflicts and gaps, and BLAST searching.

7) Select **File> Save** to save the results of your assembly project. You may also save various reports as separate files.
SeqMan Tutorials

This chapter contains five tutorials. The sections in each tutorial should be followed in order, as each is designed to walk you through a project from start to finish:

The data for each of these tutorials can be found in the following location:

- **Windows Vista/Windows 7:** `C:\Users\Public\Public Documents\DNASTAR\Lasergene 9 Data\Demo SeqMan`
- **Windows XP:** `C:\Documents and Settings\All Users\Shared Documents\DNASTAR\Lasergene 9 Data\Demo SeqMan`
- **Macintosh OSX:** `Hard Drive:Applications:DNASTAR:Lasergene 9 Data:Demo SeqMan`

The Further Exploration section at the end of the chapter highlights optional features you may wish to use as you gain experience with the software.

Assembling trace data in SeqMan Pro

Adding multiple sequences to a project

**Objective:** To create a new project and enter sequences for later assembly.

The data for this tutorial can be found in the following location:

- **Windows Vista/Windows 7:** `C:\Users\Public\Public Documents\DNASTAR\Lasergene 9 Data\Demo SeqMan`
- **Windows XP:** `C:\Documents and Settings\All Users\Shared Documents\DNASTAR\Lasergene 9 Data\Demo SeqMan`
- **Macintosh OSX:** `Hard Drive:Applications:DNASTAR:Lasergene 9 Data:Demo SeqMan`

1) Launch SeqMan. The Unassembled Sequences window and an empty Project Summary window will appear.

   **Note:** The Project Summary window will remain empty until after you assemble your sequences.

2) Click **Add Sequences** at the top of the Unassembled Sequences window. The Enter Sequences (Win) or Add to Project window (Mac) opens.
3) Locate and double-click the folder called **Demo SeqMan**. In the pane at the top of the dialog (Mac) or left of the dialog (Win, shown below), you should see a list of sequences with the names Sample 1...Sample 14. Each of the fragment sequences is a PE Applied Biosystems, Inc. automated sequencer trace file.

![Enter Sequences dialog](image)

4) Add all 14 fragment sequences to the Selected Sequences (Win) or Chosen Files (Mac) pane by clicking **Add All** (Win) or **Add File** (Mac). Then click **Done**.
5) The Unassembled Sequences window now contains a list of the fourteen sequences. Expand the window by dragging its lower right corner until you can view all the sample names simultaneously.

![Unassembled Sequences window](image)

Proceed to the next tutorial.

**Preparing sequences for assembly**

Before assembly, it is recommended to implement pre-assembly options such as removal of vector and contaminant sequences.

**Objective:** To remove the Janus vector sequence from the samples and to trim sequence ends based on SeqMan’s trace quality evaluation.

1) Make sure all fourteen of the sequences in the Unassembled Sequences window are highlighted by selecting **EDIT > Select All**.

2) Specify the vectors to search for by choosing **Janus** from one of the vector lists and **InvJanus** from the other.

**Hint:** If a vector does not appear on the list, you can add it to the vector catalog using **PROJECT > Vector Catalog**.
3) Click **Options** to open the Assembly Options dialog. Use this dialog to choose whether to trim poor quality and vector sequence and whether to remove reads containing contaminating sequence.

![Assembly Options dialog](image)

4) Preserve the default settings and click **Scan All**. SeqMan will scan for the vector you selected, perform quality trimming on sequence ends and establish the optimal sequence assembly order.

Note that checkmarks now appear next to all of the Janus vector names in the Vector column and upside down question marks appear next to the InvJanus names. Each check indicates that the vector was detected in that sequence. Upside down question marks indicate that the vector was not found in that sequence.

The Limits column displays the new sequence endpoints, reflecting both quality trimming and vector removal.

Proceed to the next tutorial.

**Viewing trace data**

**Objectives:** To view the Trim Report, then to examine the Trace Data view for one of the trimmed sequences.

1) Select **PROJECT > Trim Report** to open a report showing current end-trimming parameters, followed by the name of each sequence, its average quality, amount trimmed, and both trimmed and pre-trimmed lengths. You can expand the Trim Report window by dragging its lower right corner.

2) Close the report when you are finished viewing it.
3) From the Unassembled Sequences window, double-click **Sample 8.abi** to open its chromatogram in a separate window, as shown below:

Data trimmed from the 5’ end appears dimmed, denoting that it will not be included during sequence assembly. Note the good quality of most of the trimmed portion of the sequence. It was trimmed here because the sequence originates from the Janus vector. A vertical black bar appears at the intersection between trimmed and untrimmed sequence at base 45. It is possible to drag this bar left to unmask data that you feel should be included in the assembly, or right, to mask data that should not.

4) Select **EDIT > Go To Position**, type **500** into the Position text box and click **OK**. Note that the peak quality falls in this region, and that beyond base 507, SeqMan determined that average peak quality falls below the medium stringency threshold. This data could be recovered, if desired, by dragging the bar at the end of the sequence.

5) Close the Trace Data window.

Proceed to the next tutorial.

**Assembling and checking coverage**

**Objectives:** To assemble the fourteen fragments, then to use the Strategy View to examine the number of conflicts and degree of coverage for the resulting contig.

1) Click **Assemble** to assemble the 14 sequences into a single contig. The Assembly Report window appears.

2) Expand the Assembly Report window and scroll upward to review the data, which includes assembly parameters, sequences used, contigs created, preassembly time and total assembly time. When you are finished, close the window.

3) In the Project Summary window, click on “**Contig 1**” to select it and select **CONTIG > Strategy View** to open the following window.
Note: Click only on the name “Contig 1” and not in the open box beside the name. Clicking on the box beside the name will change the icon to a padlock, indicating that the contig has been “locked” and preventing any further editing. To “unlock” a contig, simply click once on the padlock icon, or select CONTIG>Unlock Contig.

4) Enlarge the Strategy View by dragging its lower right corner down to view all of the samples.

Note the colorful Coverage Threshold graph that appears just below the ruler. The color and thickness of the band represent the coverage within the assembly as it compares to the threshold parameters defined under PROJECT>Parameters>Strategy Viewing & Coverage.

The thick green band that appears between 200 and 900 denotes a region sequenced on both strands and meeting the Coverage Threshold criteria. The medium blue line to its right indicates a region sequenced in one direction only.

The thin red line appearing at each end of the contig means the region was sequenced only once.

5) Check the Conflicts box at the top left of the window to view a histogram showing agreement between fragment sequences. Notice that the conflict score plotted on the histogram is overall very low, indicating little or no conflict in most areas.

Proceed to the next tutorial.
Comparing consensus & restoring sequence ends

Prior to assembling the contig, SeqMan trimmed ends for the constituent sequences based on trace data quality and presence of vector. Although sufficient data remained to assemble the sequences into a single contig, there are cases when restoring some of the trimmed data may allow SeqMan to join multiple contigs into a single contig. You may also wish to restore data in order to verify the consensus in a low-coverage area.

Objectives: To use the Alignment View to restore trimmed ends manually and to compare the results of two consensus calculation methods.

1) From the Strategy View, zoom in using until you can see and double-click on the ruler around base 50. This opens the Alignment View for that region.

The Alignment View displays the consensus sequence at the top of the window, with constituent sequences listed in the lower part.

2) Click on the triangle to the left of the word “Consensus” to compare two consensus sequences calculated using different methods. A line opens under the original consensus, and the names of the calculation methods are displayed. Any differences between the primary method (Trace) and comparison method (Majority) appear in red.

3) In the list of constituent sequences, note that Sample 9 has a number of conflicts, indicated in red. View the underlying trace data for Sample 9 by clicking on the triangle to the left of the sequence name.

4) Restore data to the Sample 9 sequence by dragging the left trim bar, which appears as a black triangle on the left end of the sequence. Note that previously trimmed sequence is easily recognized by its bright yellow background, visible as shading in the graphic below. Drag the trim bar to position 0.
**Note:** Restoring trimmed sequence often reveals conflicts between the restored data and the consensus sequence.

5) To view conflicts in the newly-restored sequence more easily, close the trace data by once again clicking on the dark triangle to the left of **Sample 9**.

The red letters appearing in the leftmost portion of the **Sample 9** sequence signify conflicts between the restored data and the consensus. In this case, sequence had originally been trimmed due to inferior peak quality. It is sometimes beneficial to restore such data. On the other hand, data removed due to vector contamination would have been characterized by normal peak quality in combination with a high number of conflicts. Regardless of its deceptively high peak quality, it is not recommended that you restore vector data.

Before continuing, you may wish to view an example of why the Trace consensus call is often superior to the simple Majority consensus. At **position 79**, the Trace consensus call remains **G** even though the **Sample 9** call is **C**. That’s because the Trace method judges the peak quality, while the Majority method (which calls **S**) does not get the correct consensus here.

6) Open the trace data for **Sample 9** again and slide the trim bars toward the central sequence again until the trimmed (highlighted) data are no longer visible.

7) Click on the Project Summary window and select **FILE>Close** to close the current project.

8) Click **No** (Win) or **Don’t Save** (Mac) when prompted to save the changes.

**Assembling 454™ data in SeqMan Pro**

**Objective:** To assemble *.sff files from 454™ using the Pro Assembler.

The data for this tutorial can be found in the following location:

- **Windows Vista/Windows 7:** `C:\Users\Public\Public Documents\DNASTAR\Lasergene 9 Data\Demo SeqMan\SFF Demo`
- **Windows XP:** `C:\Documents and Settings\All Users\Shared Documents\DNASTAR\Lasergene 9 Data\Demo SeqMan\SFF Demo`
- **Macintosh OSX:** `Hard Drive:Applications:DNASTAR:Lasergene 9 Data:Demo SeqMan\SFF Demo`

1) Launch SeqMan. The Unassembled Sequences window and a Project Summary window (“Untitled.sqd”) will appear.
2) Click the Add Sequences button located at the top of the Unassembled Sequences window. The Enter Sequences (Win) or Add to Project (Mac) window is displayed.

3) Open the SFF Demo folder and select ecolireads.sff.

4) Click Add (Win) or Add File (Mac) and then click Done. The 1,154 sequences from the .sff file will be added and displayed in the Unassembled Sequences window.

5) Go to Project>Parameters to open the SeqMan Parameters dialog.

6) Select Assembling from the list on the left, and make sure that “Use Pro Assembler” is selected as the Assembly Method.

7) Since the *.sff file contains some short sequences, we need to change the Minimum Sequence Length parameter so that the shorter sequences will be included in the assembly. Change the Minimum Sequence Length value to 40.

8) Also change the Maximum Mismatch End Bases to 0. This setting is typically recommended for 454™ data, as it allows each entire read to be used when computing pairwise similarity. Your SeqMan Parameters window should appear as shown on the following page:

9) Next, choose Strategy Viewing & Coverage from the list on the left. Change the Maximum Expected Coverage value to 40. This value represents the depth of coverage expected in this assembly. Once the sequences are assembled, areas exceeding this maximum value will be indicated by thick, red areas in the Coverage Threshold graph found in the Strategy View.
10) Click **OK** to close the SeqMan Parameters dialog and return to the Unassembled Sequences window.

11) Next, Click the **Assemble** button. Notice that 1,148 of the 1,154 reads are assembled into one contig, as shown in the Project Summary window.

12) To find out why some sequences were not added, scroll up in the **Report** window that is open on your screen to view the contents. Typically, information about sequences not added is found at the beginning and the end of the report. In this case, there is no information at the beginning, but notice at the bottom of the report, the following notification is given: “Single sequence contigs were not added to your assembly.” This lets us know that the 6 sequences not included in the assembly were likely all single sequence contigs.

13) Go to **Sequence>Add** to view the remaining 6 sequences.

14) To allow these 6 sequences to be assembled into the existing contig, we will need to relax our assembling parameters. Go back to **Project>Parameters** and select **Assembling** from the list on the left.
15) Reduce the **Match Size** to 15 and the **Minimum Match Percentage** to 55, so that your parameters appear as shown below:

16) Click **OK** to return to the Unassembled Sequences window.

17) Click the **Assemble** button. The remaining 6 sequences are added to the existing contig, as shown in the Project Summary window.
18) Double-click on **Contig 2** to view your assembly in the Alignment View.

![Alignment View](image)

19) Click anywhere within a sequence to select that sequence, and then go to **Sequence>Show Original Trace/Flowgram Data**. The flowgram for the read you selected is displayed.

![Flowgram](image)

20) Click and hold the button located in the top left corner of the flowgram window and select from the list provided. The Quality scores for each called base will be displayed. For bars that represent more than one base, the quality score for each consecutive base will be listed in order of orientation from bottom to top.
21) Scroll to either end of the sequence you selected in the flowgram window. Grayed out sequence may appear, representing trimmed sequence.

22) You may grab the trim bar located on either end of your sequence and drag it to the left or right to either restore previously trimmed sequence, or to manually trim the ends.

Note: Some .sff files may already contain trimmed portions of sequence, representing removed adapter sequence. These sections of data cannot be restored.

23) Close the flowgram window. Then, select CONTIG>Strategy View to view a graphical summary of each constituent sequence in your contig.

24) Click the button several times to zoom-in on the Strategy View until you can clearly see the thick, red areas in the Coverage Threshold graph around position 5500. These red sections indicate areas of your assembly that exceed the Maximum Expected Coverage value that we defined as 40 prior to assembly.
25) Double-click on one of the red bars to launch the Alignment View for that area of the assembly. From the Alignment View, you can visually assess the coverage for the indicated area. If the coverage appears too deep, you may want to turn on the **Use Repeat Handling Assembling** parameter (located under **Project>Parameters**) and then reassemble your project. In this example, the coverage is only slightly above the threshold, so we do not need to take further action.

26) Close all open SeqMan windows using **FILE > Close**. When prompted to save the document, click **No** (Win) or **Don’t Save** (Mac).

**Assembling sequences in groups**

**Objective**: To assemble the forward and reverse paired end reads for 3 different samples, each into its own contig, but against the same reference sequence.

The data for this tutorial can be found in the following location:

- **Windows Vista/Windows 7**: C:\Users\Public\Public Documents\DNASTAR\Lasergene 9 Data\Demo SeqMan
- **Windows XP**: C:\Documents and Settings\All Users\Shared Documents\DNASTAR\Lasergene 9 Data\Demo SeqMan
- **Macintosh OSX**: Hard Drive:Applications:DNASTAR:Lasergene 9 Data:Demo SeqMan

1) Launch **SeqMan**.

2) Click the **Add Sequences** button from the Unassembled Sequences window.

3) Locate and open the **Demo SeqMan** folder.

4) Do one of the following:
   - On Windows: Double-click on the folder **SNP Demo** and then click **Add All**.
   - On Macintosh: Select **SNP Demo** and click **Add Folder**.

5) When all sequence names appear in the Selected Sequences pane (Win) or the folder appears in the Chosen Files pane (Mac), click **Done**.
6) In the Unassembled Sequences window, select the sequence named **Reference.seq**, and click the **Mark Ref** button. The sequence is selected as the reference sequence and its name is shown in italics.

7) Click on the **Assemble in Groups** button from the top of the Unassembled Sequences window. The **Assemble in Groups** panel will be displayed in the bottom half of the window:

8) One of the SNP demo sequences will automatically be displayed in the field provided so that you can specify the portion of the name that SeqMan should use as a group identifier. Highlight **Sample1** so that SeqMan will use that portion of the sequence name to identify the sequence as part of a group.

Since the SNP demo sequences have names like Sample1_f.scf, Sample1_r.scf, Sample2_f.scf, Sample2_r.scf, etc., specifying **Sample1** as the group identifier will ensure that the forward and reverse reads for the **Sample1** sequence will be assembled together; the forward and reverse reads for the **Sample2** sequence would be assembled together; and so on.

9) Click the **Assemble** button from the bottom of the Assemble in Groups panel to begin your assembly.
10) Once the assembly has finished, notice that in the Project Summary window, three contigs have been created. Each contig is named for its group identifier and contains three sequences: the forward and reverse reads for the sample, and the reference sequence we specified:

11) Close all open SeqMan windows using **FILE > Close**. When prompted to save the document, click **No** (Win) or **Don’t Save** (Mac).

**Designing sequencing primers and improving the coverage**

The Primer Walking feature in SeqMan identifies optimal primer locations for driving the closure of gaps or for filling in areas of low coverage.

**Designing sequencing primers to improve coverage**

**Objective**: To design sequencing primers for locations surrounding areas of low coverage in an assembly.

The data for this tutorial can be found in the following location:

- **Windows Vista/Windows 7**: C:\Users\Public\Public Documents\DNASTAR\Lasergene 9 Data\Demo SeqMan
- **Windows XP**: C:\Documents and Settings\All Users\Shared Documents\DNASTAR\Lasergene 9 Data\Demo SeqMan
- **Macintosh OSX**: Hard Drive:Applications:DNASTAR:Lasergene 9 Data:Demo SeqMan

1) Launch SeqMan, if it is not already open.

2) Select **SEQUENCE > Add**.

3) Locate and open the **Demo SeqMan** folder.
4) Do one of the following:
   - **Windows**: Ctrl + click on Sample 1.abi and Sample 6.abi, then click **Add**.
   - **Macintosh**: Double-click on Sample 1.abi and Sample 6.abi.

5) When both sequence names appear in the Selected Sequences pane (Win) or Chosen Files pane (Mac), click **Done**.

6) Click **Assemble** to create a contig. When the assembly is complete, the Report window appears along with the Untitled window listing the contig, the length, number of sequences and position.

7) Close the Report window.

8) In the Project Summary window, click on “**Contig 1**” to select it.

   ![Untitled sqd](image)

   **Note**: Click only on the name “Contig 1” and not in the open box beside the name. Clicking on the box beside the name will change the icon to a padlock, indicating that the contig has been “locked” and preventing any further editing. To “unlock” a contig, simply click once on the padlock icon, or select **CONTIG>Unlock Contig**.

9) Display the Strategy View by selecting **CONTIG > Strategy View**.

   ![Strategy of Contig 1](image)
Note: The two trace files that make up this contig are from upper and lower strands and overlap at all but the ends of the contig. The overlaps are green.

Click the bottom right corner of the Strategy View window and drag it to create a larger viewing window. If desired, use the zoom in tool to increase scale of the Strategy View.

10) Select CONTIG > Primer Walk... to view the Primer Walking setup parameters.

11) Click the Improve Coverage radio button to select a search for coverage primers.

12) Click the Require Clone Coverage checkbox to eliminate primers selected in areas that have no sequence coverage on the same strand as the primer.

13) Click OK to locate sequencing primers. The Primer Walking Report appears.
14) Double-click the top-scoring primer from the Primer Walking Report to open the Alignment view displaying the primer you selected.

![Alignment of Contig 1](image)

15) Select **CONTIG > Strategy View**. The Strategy view window shows a thin red horizontal line under the Coverage Threshold graph around base pair 100 corresponding to the bottom strand sequencing primer.

![Strategy of Contig 1](image)
16) Double click on the primer shown around base pair 100 to open the Alignment view displaying Contig 1.

![Image of SeqMan - Alignment of Contig 1](image)

17) Click on the **Primer Walking Report** to bring it into view.

18) Select **FILE > Save Primer Info**.

19) Choose a location and file name. Make sure **Tab-Separated** is selected from the **Save As Type** (Win) or **Format** (Mac) pull down menu to save all of the primers within the report as a tab-separated text file.

20) Click **Save**.

21) Click on the Project Summary window and select **FILE>Exit** to close the current project and SeqMan.

22) Click **Don’t Save** (Mac) or **No** (Win) when prompted to save changes.

---

**Discovering SNPs**

**Aligning sample sequences**

**Objective:** To align sample sequences to a reference sequence.

The data for this tutorial can be found in the following location:

- **Windows Vista/Windows 7:** C:\Users\Public\Public Documents\DNASTAR\Lasergene 9 Data\Demo SeqMan
- **Windows XP:** C:\Documents and Settings\All Users\Shared Documents\DNASTAR\Lasergene 9 Data\Demo SeqMan
- **Macintosh OSX:** Hard Drive:Applications:DNASTAR:Lasergene 9 Data\Demo SeqMan
1) Launch SeqMan.

2) In the Unassembled Sequences window, click the **Add Sequences** button.

3) Locate and open the **Demo SeqMan** folder.

4) Do one of the following:
   - Windows: Double-click on the folder **SNP Demo** and then click **Add All**.
   - Macintosh: Select **SNP Demo** and click **Add Folder**.

5) When all sequence names appear in the Selected Sequences pane (Win) or the folder appears in the Chosen Files pane (Mac), click **Done**.

6) In the Unassembled Sequences window, select the sequence named **Reference.seq**, and click the **Mark Ref** button. The sequence is selected as the reference sequence and its name is shown in italics.

   ![Unassembled Sequences window](image)

   **Note:** A reference sequence is a known sequence used for comparison with your sample sequences. In SNP discovery, SeqMan will determine where your sample sequences differ from the reference sequence.

7) Select **PROJECT > Parameters > Pair Specifier**. The Pair Specifier dialog appears.

8) Select **sample_f.abi <> sample_r.abi** from the Pair Pattern drop-down menu.
9) In the Verify Pattern section, type in **Sample1_f.scf** in the Forward field and **Sample1_r.scf** in the Reverse field. The Success message indicates that the example names match the pair pattern you selected.

![SeqMan Parameters](image)

10) Click **OK** to save the changes and close the SeqMan Parameters dialog.

11) Click **Assemble**. After assembly is complete, close the Report window. The sample sequences align into a single contig with the reference sequence.

**Note:** After assembly, whenever the reference sequence is displayed, it appears at the top of the lower pane of the Project Summary window with its name in italics.

Please proceed to the next tutorial.
Reviewing SNPs

Objective: To review SNPs using the Strategy view, Alignment view, and SNP Report.

1) From the top pane of the Untitled window, click Contig 1, and then select CONTIG > Strategy View to display an overview of the contig. Click the Zoom In button and drag the lower right corner of the window to enlarge the view.

2) Select SNP > Show SNPs to change the display of the Strategy View as follows:

When you look at this view, notice the following:

- Bold arrows represent sample sequences. A light arrow overlapping a sample sequence arrow represents the sequence that is paired with the sample.
- Locations of bases in the contig that correspond to SNP base locations in the aligned sample sequences are indicated with hash marks on the contig goalpost.
- Locations of bases annotated as features of the type “variation” in the Reference.seq file are indicated with green hash marks on the reference sequence arrow.
- Locations of bases in sample sequences identified as putative SNPs by SeqMan are indicated with blue hash marks on the sequence arrows.
- Locations of bases in sample sequences identified as rejected SNPs by SeqMan are indicated with red hash marks on the sequence arrows.
3) Select **CONTIG > Alignment View**, and drag the lower right corner of the window to enlarge the view, so that it looks like the following window.

![Alignment of Contig 1](image)

When you look at this view, notice the following:

- Bases annotated as features of type “variation” in the reference sequence file are displayed in green. The ‘T’ in position 58 is an example.

- Bases in sample sequences identified as putative SNPs by SeqMan are displayed in blue throughout the view.

- A base in a sample sequence that SeqMan has determined is a heterozygous putative SNP is displayed using the appropriate ambiguity code.

4) Select **SNP > SNP Report**. When you look at the window, notice the following:

- Tabs on the SNP Report allow you to change the display between two different SNP reports: **All Found SNPs** and **SNPs Summary**.

- A row in the **All Found SNPs** report lists information for a single SNP base in a sample sequence.

- A row in the **SNPs Summary** report summarizes information for all of the SNP bases in an aligned column.

**Note:** For further analysis, information in the SNP Report window can be copied and pasted into other documents such as MS Excel spreadsheets. The SNP report can also be saved in tab-separated file format by selecting **FILE > Save SNP Report for ‘Contig 1.’**
5) Select SNP > Sort by SNP.

6) In either the All Found SNPs or the SNPs Summary report, select a row and then press the up and down arrow keys to select other rows. As you do so, notice that the corresponding SNPs are selected in the Alignment View, allowing you to quickly scan through the SNP bases.

Because you selected SNP > Sort by SNPs, sample sequences in the Alignment View are reordered automatically according to the SNP bases in the selected column. Sample sequences with SNP bases in the aligned column are sorted to the top and samples with non-SNP bases are sorted to the bottom.
Note: A sample sequence in the Alignment View can be manually reordered by clicking on its name and dragging it up or down. Selecting CONTIG > Sort > by Offset or CONTIG > Sort > by Name automatically reorders sample sequences by offset or name.

Proceed to the next tutorial.

Analyzing putative SNP bases

Objective: To analyze putative bases and determine if you want to confirm or reject them as actual SNPs.

1) Select PROJECT > Parameters > SNP Discovery to view the parameters that SeqMan uses to identify SNPs.
2) Notice the following default settings:

- **Minimum Score at SNP:** This parameter prevents bases with a quality score of less than the threshold value from being shown in the SNP Reports.

- **Minimum Neighborhood Score:** This parameter prevents SNPs with a neighborhood quality score of less than the specified value from being displayed. Note that if the specified Neighborhood Window (see below) contains one or more mismatches to the reference sequence, the putative SNP will be rejected, even if it meets the Minimum Neighborhood Score threshold.

- **Neighborhood Window:** This value specifies the size of the window to be used when calculating the neighborhood quality score. For example, if this value is set to 5, then the 5 bases upstream and the 5 bases downstream from the SNP base will be considered.

- **Heterozygous Peak Threshold:** By default, any base that exhibits a secondary trace peak that is at least 50% of the intensity of the primary peak will be identified as heterozygous.

3) Click OK to close the SeqMan Parameters dialog without making any changes.

4) In the SNP Report window, click on the **All Found SNPs** tab and look at the first column, which is labeled **SNP**. A question mark in this column indicates that the SNP base is putative, a checkmark that it is confirmed, and an ‘x’ indicates that it is rejected as an actual SNP.
5) In the SNP Report window, click the **SNPs Summary** tab.

6) Look at the **SNP** column in the **SNPs Summary** report. The question marks in this column indicate putative SNP bases.

7) Locate the row in the SNP Summary report for contig position 58.

8) Double click on the contig position in the row. The Alignment View is displayed with the column at position 58 selected.
9) Display the traces for all of the sequences in the Alignment View by holding down the **Alt/Option** key (Win/Mac) while clicking on any of the triangles next to a sequence name.

10) Examine the trace data for the bases aligned in position 58. Notice that 4 sequences show a “y” (the ambiguity code for C or T). Upon examining the trace data for these sequences, we can see that all 4 sequences show peaks for both C and T at position 58. The forward and reverse sequences for **Sample 3** clearly show a C peak. Comparing this information to the reference sequence, which is a T at position 58, we can find that the putative SNP bases in column 58 can be confirmed as actual SNPs.

11) In the SNPs Summary report, click on the row for contig position 58 to highlight it, then select **SNP>Confirm SNP**. The mark changes to a checkmark to indicate that you are confirming that the putative SNP bases in the column are actual SNPs. In the Alignment View, the color of the SNP bases in the column changes to green. This is the default color for confirmed SNP bases.
12) Click on the Project Summary window and select **FILE>Close**. When prompted to save the document, click **Don’t Save** (Mac) or **No** (Win).

**Note:** The default colors for display of putative, confirmed, and rejected SNP bases, as well as non-SNP bases, can be changed in the dialog opened by selecting **PROJECT > Parameters > SNP Discovery**.

---

**Further Exploration**

**Working with features**

SeqMan enables you to display, edit, and create new features for the sequences in your project. Features are read from *.seq and *.sbd files, as well as existing SeqMan projects. (*.sqd). You can also import features for your sequences through BLAST searching.

- Any sequences in your project that are not already associated with trace or flowgram data can be annotated with features within the Alignment View. To create a new feature, first select the range for the new feature on the sequence where you wish to create it, and then select **FEATURES>New Feature**.

- The Feature Table allows you to view and manage all of the features within your current project. Display the Feature Table by selecting **FEATURES>Show Feature Table**. To display the Feature Table for the consensus sequence, first open the Strategy View by selecting **CONTIG>Strategy View**, and then select **FEATURES>Show Consensus Feature Table**.

- View features in the Alignment View by clicking the triangle shown to the left of the sequence name.

- Features that have been added to the consensus sequence are displayed in the top section of the Strategy View beneath the Depth of Coverage Graph.

- To edit a feature, first select it by clicking on it in the Alignment View or in the Feature Table. Then, select **FEATURES>Edit Feature**. Alternately, double-click on the feature you wish to edit from the Alignment View or Strategy View.
• To collect features for sequences in your project through BLAST searching, first select the range of sequence you wish to BLAST from the Alignment View. Then, select **NET SEARCH>BLAST selection**. After the search is complete, click the **Collect Features** button at the top of your BLAST results window. (Note that the **Collect Features** button will not be available if the sequence you selected to BLAST is already associated with trace or flowgram data).

• When exporting the consensus sequence to SeqBuilder by using **FILE>Send Consensus To>SeqBuilder**, SeqMan automatically annotates the sequence with features for areas of high and low coverage, as well as confirmed SNPs.

**Importing Phrap, Newbler, and Sequencher data**

Phrap, Newbler, or SeqMan NGen assemblies with the *ace* extension and Sequencher assemblies with the *spf* extension may be opened in SeqMan using **FILE > Import**.

The Alignment View for an imported Phrap project displays Phred base calls and Phrap consensus calls. By default, the top consensus (next to the word *Translate*) is the Imported Phrap consensus. Just below this is the SeqMan *Trace* or *Majority* consensus. These consensus only show differences from the Phrap consensus based on the original Phrap assembly.

**Using the vector catalog**

SeqMan contains a catalog for a number of common vectors. To add, delete, or modify entries in the catalog, select **PROJECT > Vector Catalog**.
Handling repetitive and contaminant sequences

To remove contaminant sequences, use the following procedure.

1) Store sequence files of known contaminants in the **Contaminant Seqs** folder located:
   - **Windows Vista/Windows 7**: C:\Users\Public\Public Documents\DNASTAR\Lasergene 9 Data
   - **Windows XP**: C:\Documents and Settings\All Users\Shared Documents\DNASTAR\Lasergene 9 Data
   - **Macintosh OSX**: Hard Drive:Applications:DNASTAR:Lasergene 9 Data

2) Prior to sequence assembly, select **PROJECT > Contaminant Seqs** and select which to screen for from the list of available files.

3) From the Unassembled Sequences window, click **Options** and check **Remove Contaminant Sequences**.

To add known repetitive sequences last to an assembly, use the following method.

1) Store sequence files of known repetitive sequences in the **Repetitive Seqs** folder located:
   - **Windows Vista/Windows 7**: C:\Users\Public\Public Documents\DNASTAR\Lasergene 9 Data
   - **Windows XP**: C:\Documents and Settings\All Users\Shared Documents\DNASTAR\Lasergene 9 Data
   - **Macintosh OSX**: Hard Drive:Applications:DNASTAR:Lasergene 9 Data

2) Prior to sequence assembly, select **PROJECT > Repetitive Sequences** and select which files you wish to screen for in the current project.

3) From the Unassembled Sequences window, click **Options** and check **Optimize Sequence Assembly Order**.

**Note:** Optimizing assembly order is a parameter under the Classic assembler only, and is recommended for most assemblies using the Classic assembler whether or not repetitive sequences are specified.
**Negating weights**

To cancel the internal weight for a selected portion of a sequence so that it does not contribute to the consensus, highlight the region of sequence in the Alignment View and select **EDIT > Negate Weights**. This command is particularly useful when building the assembly around a “backbone” sequence from a closely related species. Use **EDIT > Restore Weights** to restore.

**Exporting data**

- To save an assembly project, select **FILE > Save**.
- To export all the constituent sequences for one or more contigs, select **CONTIG > Export Sequences**.
- To export the consensus sequence for one or more contigs, select **CONTIG > Save Consensus**.
- To export your assembly as a GenVision project, select **FILE>Export as GenVision Project** from the Strategy View.
- To export assembly projects as a Phrap project (*.ace), select **FILE > Export Project**.
MegAlign

Overview

MegAlign generates pairwise and multiple sequence alignments of DNA and/or protein. MegAlign can also create phylogenetic trees, as well as reports and tables showing the numerical data underlying the comparisons.

MegAlign can utilize sequence files from a wide variety of file types or from NCBI’s BLAST or Entrez databases. If a sequence file is longer than you need, you may specify a portion of the sequence by coordinates, by selecting a feature from the feature table, or by highlighting a sub-region of a previously aligned project.

The following four algorithms are available for pairwise alignments:

- The Wilbur-Lipman Method constructs tables of K-tuples to find regions of similarity between two or more DNA sequence pairs using the method of Wilbur and Lipman (1983). The method reads the sequences, builds case structures of the K-tuples, finds the diagonals and matches, and creates the finished alignment.


- The Lipman-Pearson Method constructs tables of K-tuples to find regions of similarity. The alignment is then optimized using a trimmed-down version of the Needleman-Wunsch method developed by Lipman and Pearson (1985).

- The DotPlot Method compares sequences by overlapping them, counting mismatches, then shifting the sequences one residue relative to one another and counting mismatches again, iteratively, for every possible position. While this method is slower than other pairwise methods, it is exhaustive and can detect long regions of slight similarity between evolutionarily distant divergent genes or proteins. Parameters may also be adjusted to limit matches to shorter regions of higher similarity. Unlike other pairwise alignments, DotPlot results are displayed as customizable graphs rather than textual alignments.
The following three additional algorithms are available for **multiple** alignments:

- **The Jotun Hein Method** aligns all sequences in the Worktable using the method of Hein (1990). The Jotun Hein method builds a phylogenetic tree by examining sequence pairs and creating the best possible arrangement of ancestral branches. The method is most useful when aligned sequences are known to be related by descent.

- **The ClustalV Method** aligns all the sequences in the Worktable using the ClustalV method developed by Higgins and Sharp (1989). The Clustal Method groups sequences into clusters by examining sequence distances between all pairs. Clusters are aligned as pairs, then collectively as sequence groups, to produce the overall alignment. After a multiple alignment is completed, a neighbor-joining method is employed to reconstruct phylogeny for the putative alignment.

- **The ClustalW Method** aligns sequences using the method of Thompson et al. (1994). ClustalW was designed to create more accurate alignments than ClustalV when alignments include highly diverged sequences. However, ClustalW does not always handle end-gaps ideally, so some regions may be aligned better using the ClustalV method. Also, note that true ClustalW performance is only achieved when you choose the default “Slow-Accurate” option in the Method Parameters rather than the “Fast-Approximate” method.

Sequences may be realigned using different alignment parameters, and manual adjustments may be made using the Worktable palette tools. Once you are satisfied with the alignment, the versatile Alignment Report allows you to create a customized display of results. Your alignments may also be displayed in the form of a phylogenetic tree. Bootstrapping analysis may be applied to the tree when one of the Clustal algorithms is used to align your sequences.

**10 Quick-Start Steps for Using MegAlign**

Here are ten basic steps for using MegAlign:

1) Select **FILE > New** to open a new project or **FILE > Open** to open a previously saved project.

2) Add sequences to the Worktable as directed in the tutorial. You can use a sub-range of a sequence, and if necessary, you can select **OPTIONS > Font** and **Size** to reformat characters until they are clearly legible.

3) View and edit weight tables using **ALIGN > Set Residue Weight Table**.
4) If you do not want to use the Standard Genetic Code, select OPTIONS > Genetic Codes. Codes may be edited using OPTIONS > Edit Genetic Code. Genetic codes are only important if you will be aligning DNA and protein sequences together, or translating DNA.

5) Choose a pairwise or multiple alignment method. For pairwise methods, first highlight two or more sequence names by using Ctrl/Cmd+click (Win/Mac) or Shift+click. For multiple alignments, all sequences in the Worktable are aligned whether or not they are highlighted. You may want to edit the ALIGN > Method Parameters before performing the alignment. To undo a multiple alignment, select ALIGN > Unalign All.

6) If you have performed a multiple alignment, you may edit gaps in the alignment from the Worktable or realign residues using the Worktable palette tools. To locate a particular position in a sequence, select EDIT > Go To Position or EDIT > Find Disagreement. Search commands can be used for unaligned or multiple aligned sequences, but not for pairwise alignments.

7) To examine numerical data about completed alignments, use the Alignment Report, Sequence Distances, Residue Substitutions or Phylogenetic Tree commands from the VIEW menu.

8) If desired, customize the OPTIONS > Alignment Report Contents. You can select OPTIONS > New Consensus and OPTIONS > New Decoration to change the appearance of the report and the definition for the consensus.

9) Select FILE > Print your results, if desired.

10) Select FILE > Exit (Win) or MEGALIGN > Quit MegAlign (Mac) to exit MegAlign.

---

**MegAlign Tutorials**

The tutorials in this chapter should be followed in order, as they are designed to walk you through an example MegAlign project from start to finish. The Further Exploration section at the end of the chapter highlights optional features you may wish to use as you gain experience with the software.

**Entering sequences using drag and drop**

Drag and drop is a feature available in all Lasergene applications, and is very useful for entering large numbers of sequences.

**Objective:** To add two sequences to the MegAlign Worktable using the drag and drop procedure.
The data for this tutorial can be found in the following location:

- **Windows Vista/Windows 7**: 
  C:\Users\Public\Public Documents\DNASTAR\Lageregene 9 Data\Demo MegAlign\Histone Sequences

- **Windows XP**: 
  C:\Documents and Settings\All Users\Shared Documents\DNASTAR\Lageregene 9 Data\Demo MegAlign\Histone Sequences

- **Macintosh OSX**: 
  Hard Drive:Applications:DNASTAR:Lageregene 9 Data:Demo MegAlign:Histone Sequences

1) Launch MegAlign.

2) Using Windows Explorer or Macintosh Finder, locate and open the **Histone Sequences** folder.

3) Highlight both **Tethis21.seq** and **Tethis22.seq** using **Shift+click** or a similar method.

4) Use the mouse to drag the selected files onto the MegAlign Worktable (Win) or MegAlign program icon in the dock (Mac) and drop them there. The MegAlign Worktable will appear as follows:

![MegAlign Worktable](image)

**Note:** If **tethis22.seq** appears before **tethis21.seq**, rearrange the sequences so that tethis21.seq appears first. You can do this by first selecting the sequence you want to move, and then dragging it to the desired position in the list.

- You may select **OPTIONS > Size** to increase or decrease the font size.

- The left pane of the worktable displays the first (starting) base pairs of both sequences. The right pane displays the final (ending) base pair of the longest sequence. In this case, because the sequences are almost the same length, the final base pairs of both sequences appear in the right pane.
Setting ends using features

In MegAlign, you may set sequence ends by typing in the desired coordinates or by selecting a feature.

**Objective:** To set sequence ends using one of the GenBank features imported automatically when the sequences were entered.

**Note:** The lengths of these sequences are 906 bp for Tethis21 and 905 bp for Tethis22.

1) Select **tethis21.seq** by clicking its name in the left pane of the Worktable.

2) Select **OPTIONS > Set Sequence Limits > From Feature Table**. The Feature List appears.

3) You can use this dialog to see the length of a sequence in the “Segments” section of the dialog.

4) Highlight the **histone H2B-1—CDS** feature in the upper pane of the dialog. The lower pane now shows the feature name and range (232 > 600) of the highlighted feature.

5) Click **Change the Rest** to limit the **tethis22** sequence using the same feature.

6) Click **OK** to return to the MegAlign Worktable.
Note that the selected range of the tethis21 sequence has limited the range of both original sequences on the worktable. Notice that the worktable now reflects that both sequences end at bp 369.

**Performing a pairwise alignment**

Since the current sequences are DNA, the pairwise methods available are Wilbur-Lipman, Martinez-Needleman-Wunsch and DotPlot.

**Objective**: Use the Wilbur-Lipman method to align two sequences.

1) Hold down the **Shift** key while you click each of the two sequence names to highlight them. Because there may be many sequences, MegAlign always needs to know which pairs you wish to align.

2) Select **ALIGN > One Pair > By Wilbur-Lipman Method**. The method parameter dialog opens.

3) Click **OK** to use the default parameters for the alignment. MegAlign calculates the alignment and displays results in the Alignment View, shown below.

In the lower portion of the Alignment View, the aligned pair of sequences flanks a central consensus that shows mismatches as spaces. The window header displays the similarity index (percent of all residues that are matching), gap number, total gap length and consensus length.
4) Change the color scheme of the window by clicking 🎨. The Alignment View Options dialog appears.

5) From the Match Color list, select **Blue**. All matching residues immediately turn blue on the Alignment View.

6) Repeat step 5, choosing **Red** for Mismatch Color and **Green** for Consensus Color.

7) Check and uncheck each of the four boxes just under the color selection boxes, and note how the Alignment View changes.

8) Click **Vertical Bars** to show agreement between the two sequences as vertical lines instead of letters.

9) Once you have finished experimenting with the Alignment Color dialog, close it using the close icon in the title bar.

10) Close the Alignment View to return to the Worktable.

**Performing a Dot Plot pairwise alignment**

The Dot Plot method compares sequences by plotting matches between two sequences on a chart, with one sequence on each axis.

**Objective:** To use the DotPlot method to align two sequences.

1) Highlight the two sequence names (if not still highlighted from the previous tutorial).

2) Select **ALIGN > One Pair > Dot Plot**. The Filtered DotPlot dialog opens, allowing you to set the parameters of the alignment.
3) Leave the parameters set to their defaults, and click **OK**. The DotPlot opens in a separate window.

- Diagonal lines indicate regions of the two sequences that meet the threshold for similarity specified in the Dot Plot parameters.
- Dark blue diagonals show weaker similarities, with progressively stronger similarities indicated by pale blue, green, yellow, orange and red.
- The long red diagonal line indicates that these two sequences align well over most of their length.

4) Double-click on any diagonal line to open a window that shows the underlying alignment of that diagonal.
5) Once you have finished viewing the window, click on the Worktable and close the current MegAlign project using **FILE > Close**. When prompted to save the document, click **No** (Win) or **Don’t Save** (Mac).

### Performing a multiple alignment

**Objective**: To align fourteen calmodulin sequences using the ClustalV method.

The data for this tutorial can be found in the following location:

- **Windows Vista/Windows 7**: C:\Users\Public\Public Documents\DNASTAR\Lasergene 9 Data\Demo MegAlign
- **Windows XP**: C:\Documents and Settings\All Users\Shared Documents\DNASTAR\Lasergene 9 Data\Demo MegAlign\
- **Macintosh OSX**: Hard Drive:Applications:DNASTAR:Lasergene 9 Data:Demo MegAlign

1) Select **FILE > Enter Sequences**.

2) Locate and open the **Demo MegAlign** folder.

3) Do one of the following:
   - **Windows**: Double-click on the folder “Calmodulin Sequences” and then click **Add All**.
   - **Macintosh**: Click “Calmodulin Sequences” and click **Add Folder**.

4) When all fourteen sequence names appear in the Selected Sequences pane (Win) or the folder appears in the Chosen Files pane (Mac), click **Done**.

5) Select **ALIGN > Set Residue Weight Table**. The Residue Weight’s table appears.

   - MegAlign’s residue weight tables are used in scoring multiple alignments so that mismatched residues that are chemically similar score higher than chemically different residues.
   - For the ClustalV method, the PAM100 table should be used when aligning conserved sequences, and the PAM250 table should be used for divergent sequences. Since calmodulins are highly conserved, the PAM100 table should be used for this alignment.
6) Select PAM100 from the pull-down menu. The title bar for the current window reflects MegAlign’s default settings. The title will later change to reflect the weight table and alignment method you choose.

7) Click OK to return to the Worktable.

8) To view the current ClustalV settings, select ALIGN > Method Parameters and select the ClustalV tab.

9) Review the settings, leave the default values, and then click Later.

10) To align the sequences, select ALIGN > By Clustal V Method. The Alignment Progress window shows what percentage of the project has been aligned. When the alignment is complete, the Worktable reappears with the aligned sequences.
11) To view a table showing the divergence and percent identity of the sequences, select **VIEW > Sequence Distances**:

![Pair Distances of Untitled ClustalW (PAM100)](image)

12) To view a table showing residue substitutions, select **VIEW > Residue Substitutions**:

![Residue Substitutions of Untitled ClustalW (PAM100)](image)

13) To view the phylogenetic tree, select **VIEW>Phylogenetic Tree**.

14) To apply bootstrapping analysis to the tree, select **ALIGN>Perform Bootstrapping**. A separate window containing the bootstrap analysis settings appears.
15) Review the settings and then click OK. Bootstrapping analysis begins, and bootstrapping values are displayed on the phylogenetic tree. The numbers displayed refer to the percentage of times the same branches appear when a number of sample trees (in this case, 1000) are generated.

16) Close all windows except for the Worktable.

**Creating an alignment report**

Alignments can be modified to show, hide and highlight various components and consensi. Graphics in the Alignment Report that box, shade, or hide residues are referred to as “decorations”. On the Alignment Report you may also define and display one or more custom consensi built upon your own criteria.

**Objectives:** To modify the contents of the Alignment Report and to create a decoration that shades those amino acids that disagree with the consensus sequence.

1) Select **VIEW > Alignment Report** to open a separate window containing the results of the multiple alignment. Take a moment to review its contents.

2) To modify the contents of the report, select **OPTIONS > Alignment Report Contents**.
3) Check the box next to **Show Consensus Strength** and leave all other settings at their defaults:

![Alignment Report Contents](image)

4) Click **OK** to update the already open Alignment Report. Note the color-coded histograms showing the strength of the consensus at each base.

5) Select **OPTIONS > New Decoration**. The New Decoration dialog appears.

6) In the title box, type “Shade disagreements with consensus”.

7) The next row contains three pull-down menus. Change the first pull-down menu to **Shade** and the middle menu to **residues differing from**. Leave the third menu, the one on the right, at the default setting, **the Consensus**.
8) Choosing **Shade** caused two additional pull-down menus to open below it. Leave the color as black from the first menu and choose the darkest shading scheme from the second menu. Leave the distance units box at “0”. The dialog should now look like the one below:

![Alignment Decoration Name](image)

9) Click **OK**. In the Alignment Report window, any constituent sequence residues that do not match those in the consensus sequence now appear shaded. (The sequences may be listed in a different order in your project).
Further Exploration

Creating an alignment using a portion of the sequences

To create a new alignment from a portion of the sequences, highlight a portion of the consensus sequence in the Worktable and select ALIGN > Create Alignment From Selection. When prompted, choose a name and location for the new project and click Save. A new Worktable will open containing only the highlighted portion of sequences.

Realigning residues

After completing a multiple alignment, you may manually adjust selected portions of the alignment using the palette tools to the left of the Worktable.

- **Straighten Columns** inserts gaps preceding selected residues and aligns residues along their left sides.
- **Shuffle Right** moves gaps within selected regions so they precede the selected residues.
- **Shuffle Left** moves gaps within selected regions so they follow the selected residues.

Working with the Alignment Report

- To add a decoration to the Alignment Report use OPTIONS > New Decoration.
- To add a consensus to the Alignment Report, select OPTIONS > New Consensus. If desired, you can change the standard amino acid categories from the same dialog by clicking Set Groups then Standards.
- To add, remove or change decorations and consensi, select OPTIONS > Decorations > Decoration Manager or OPTIONS > Consensi > Consensus Manager.
Exporting data

- To export sequences as separate Lasergene DNA or protein files, highlight the names of the sequences in the Worktable and select **FILE > Export Sequences**.

- To export the consensus as a Lasergene DNA or protein file, select **FILE > Export Consensus**. Gaps in the sequence are represented by Xs.

- To export your alignment as a [GenVision](#) project, select **FILE > Export as GenVision Project(s)**. You will be given the option to export a single GenVision project, showing all of the sequences in your project as histograms, or to export one GenVision project for every sequence in the alignment. The latter option will produce a circular image for each sequence, with all of the sequences represented around the perimeter, and chords connecting the aligned, matching segments between the one single sequence and all others.

- To export the alignment for further analysis in PAUP, GCG Pileup or as a Phylip tree file, select **FILE > Save As** and select the format you want.
GeneQuest

Overview

GeneQuest aids you in identifying and annotating coding regions and other features of interest in your DNA sequence. The project begins when you enter a DNA sequence. The next step is to apply some of GeneQuest’s many analysis methods to the sequence. These methods include:

- **Title**—Adds a title to the document.
- **Ruler**—Adds a ruler to the document.
- **Sequence**—Displays the sequence on the document.
- **Patterns - Matrix**—Locates Start and Stop sites, Intron and Exon splice sites using log odds or positional frequency matrix patterns.
- **Patterns - Signal**—Uses a text-based pattern database of known DNA transcription factor sites.
- **Patterns - Type-In Pattern**—Uses patterns that have been typed in using the keyboard.
- **Repeats - Inverted Repeats**—Locates inverted repeats.
- **Repeats - Dyad Repeats**—Locates dyad repeats and palindromes.
- **Repeats - Direct Repeats**—Locates direct repeats.
- **Gene Finding - DNA Finder**—Identifies regions that match those of a user-specified DNA sequence file. Displays results separately for the top and bottom strands.
- **Gene Finding - Protein Finder**—Identifies regions whose translation matches a user-specified protein sequence file. The display combines results for all six reading frames.
- **Enzymes - Restriction Map**—Creates restriction maps using any of the enzymes from the DNASTAR enzymes catalog.
- **Coding Prediction - Borodovsky**—Uses Borodovsky’s Markov method to identify potential coding regions.
• **Coding Prediction - Starts Stops ORFs**—Locates and summarizes open reading frames longer than a user-specified minimum length. You can designate whether or not a start codon is required. Starts and stops are displayed independently for all frames.

• **Coding Prediction - Local Compositional Complexity**—Uses the Shannon information theory to find regions rich with information.

• **Base Contents - Base Distribution**—Plots the local frequency of the four bases and A+T and G+C pairings. It also plots the local strand skew of the complements AT and GC.

• **Bent DNA - Bending Index**—Predicts the bending of free DNA by showing localized angles of helix trajectory computed for a specified window size.

• **Features**—Not a true “method,” but a list of known features for the sequence.

Once the methods have been applied, the results are displayed graphically on a common horizontal scale. In addition, menu commands let you display tabular data summaries (e.g., base content, codon usage), fold a portion of the sequence as RNA, or view the predicted electrophoretic separation of restriction fragments through an agarose gel.

GeneQuest also reads and interprets features from the comment or feature panes of GenBank-formatted sequence files. Once you have discovered areas of interest in the sequence, you may create your own annotations and link several features together under a common title and description.

---

### 10 Quick-Start Steps for Using GeneQuest

Here are ten basic steps for using GeneQuest:

1) Create a new project or open an existing GeneQuest project.

2) Select **ANALYSIS > Show Available Methods** to display a list of methods, and choose which of these you would like to apply to the sequence. You may wish to follow the formal strategy for locating potential genes outlined later in this chapter.

3) Move the **methods** you want from the More Methods menu to the Method Curtain. Apply methods to the sequence by using the mouse to drag them from the Method Curtain to the assay surface, if they are not already there.

4) View the results in graphical or tabular form.

5) Edit method parameters at any time. Then add, delete, rearrange and “decorate” methods until you are satisfied with the look of the document.
6) Use the graphical and tabular results to form hypotheses about your sequence, and then annotate any interesting features.

7) Search BLAST or Entrez databases for matches to your sequence, or other sequences of interest.

8) Select **FILE > Save** to save your results.

9) Select **FILE > Print** to print your results, if desired.

10) Select either **FILE > Exit** (Win) or **GENEQUEST > Quit** (Mac) to exit GeneQuest.

---

**GeneQuest Tutorials**

The tutorials in this chapter should be followed in order, as they are designed to walk you through an example GeneQuest project from start to finish. The Further Exploration section at the end of the chapter highlights optional features you may wish to use as you gain experience with the software.

**Opening an existing project and organizing methods**

All folders referenced in this tutorial can be found in the following location:

- **Windows Vista/Windows 7**: C:\Users\Public\Public Documents\DNASTAR\Lasergene 9 Data
- **Windows XP**: C:\Documents and Settings\All Users\Shared Documents\DNASTAR\Lasergene 9 Data\n- **Macintosh OSX**: Hard Drive:Applications:DNASTAR:Lasergene 9 Data:

1) Launch GeneQuest.
2) Select FILE > Open. Locate the file WormProblem_FinalResult.dad in the Demo Data folder and double-click it to open.

![Image of assay surface](image.png)

The main portion of the window is the assay surface. It contains graphic displays of analysis methods that have already been used to analyze the sequence. The Method Curtain at left displays a list of available analysis methods.

3) Select FILE > Close to close the WormProblem_FinalResult.dad project.

4) Select FILE > New and open the WormProblem.seq file located in the Demo Data folder.

5) Select ANALYSIS > Show Legend. The Legend Curtain is displayed to the right of the assay surface. This curtain displays the names of the methods that have been applied to the assay surface.

**Note:** At this point, only the scale, sequence, as well as ORFs and Starts for the first 3 reading frames are displayed.

Proceed to the next tutorial.
Applying methods to the sequence

1) In the Method Curtain (displayed to the left of the assay surface), double-click on the method Coding Prediction-Borodovsky- volvox_0.mat so that the method parameters dialog is displayed.

2) Click Set Data File and select the ce_lo_4.mat file from the Borodovsky Matrices folder. Click Open, then click OK to close the dialog.

3) Click on the plus sign (Win) or the triangle (Mac) to the left of the method Coding Prediction – Borodovsky – ce_lo_4.mat to reveal the list of possible displays.

4) Click the white space to the left of the displays to ungroup them.

5) Shift+click each of the graph symbols next to Frames 1, 2, and 3 to select them.
6) Drag the selected displays onto the assay surface and drop them under the existing displays.

**Note:** GeneQuest calculates potential coding regions and displays them as peaks. The higher the Borodovsky peak, the higher the probability that the area is a coding region.

7) You can use colors to differentiate each frame of the newly applied Borodovsky displays from each other.

- First, click the **white space** underneath the Borodovsky displays to ungroup them.
- Then, click the Frame 1 Borodovsky display to select it.
- Select **OPTIONS > Line Color > Red**.
- Repeat the above steps for the Frame 2 and Frame 3 displays, but select **Green** for Frame 2 and **Blue** for Frame 3.

8) **Shift+click** frames 1, 2, and 3 of the Borodovsky methods, then select **OPTIONS > Superimpose Objects**.

9) In the Method Curtain, click on the **plus sign** (Win) or the **triangle** (Mac) to the left of the method **Patterns - Matrix**. Locate and select the file **celegans_ds_2.mat** from the **Matrix Patterns** folder and click **Open**. This method will now be listed in the Method Curtain. Select the **Top Strand** of this method and drag it to the bottom of your assay surface.

10) At the top of the Method Curtain, select **MORE METHODS > Patterns > Matrix**. A new entry called **Patterns - Matrix** will appear at the top of the Method Curtain.

11) Repeat steps 9-10 to add two matrix patterns **celegans_as_2.mat** and **celegans_atg_2.mat** to this new method. For each method, drag the **Top Strand** to the bottom of your assay surface.

**Note:** GeneQuest calculates potential translation start, donor and acceptor sites and displays them as vertical lines. Each apparent line is really a narrow box containing a numeric score denoting the likelihood of that area being a site.

12) To view the scores only, select the **Zoom In** tool and then click repeatedly on the assay surface until you can read the numbers inside the boxes.
13) To view the scores and other information, select the **Range Selector** tool , then click and hold on a site until an information box is displayed.

- The cursor snaps to a particular point on the site. The exact base to which the cursor snaps is shown on the header at the top left of the window next to the word “Position.”
- The pop-up information box displays the bases spanned by the pattern and a candidate ranking score.

14) Close the method curtain by selecting **ANALYSIS > Hide Available Methods**.

Proceed to the next tutorial.

**Predicting coding regions and creating features**

1) To make it easier to locate potential genes, click the **Object Selector** tool . Drag and drop the method names so they appear in the Legend Curtain in the order shown:

```
- Scale
- Sequence
  - Top Strand, braconidius & elegans acceptor - Matrix - eiegans_as_2.mat
  - Top Strand, braconidius & elegans donor - Matrix - eiegans_de_2.mat
  - ORFs - Starts Stops ORPs
    - 1, ORPs - Starts Stops ORPs
    - 2, ORPs - Starts Stops ORPs
    - 3, ORPs - Starts Stops ORPs
  - 1, Starts - Starts ORPs
    - 1, Starts - Starts ORPs
    - 2, Starts - Starts ORPs
    - 3, Starts - Starts ORPs
  - Frame - Burovsky - e_lo_4.mat
    - 1, Frame - Burovsky - e_lo_4.mat
    - 2, Frame - Burovsky - e_lo_4.mat
    - 3, Frame - Burovsky - e_lo_4.mat
  - Top Strand, braconidius & elegans start - Matrix - eiegans_atg_2.mat
```

2) Use the **Object Selector** tool to select each matrix pattern result in turn, then use the **OPTIONS** menu to change the **Line Color**. For example, choose green for the donor sites, blue for the acceptor sites, and black for the start sites.

3) Use the **scroll bar** at the bottom of the window to locate the area of the sequence from 9,000-12,000 bp. Use the **Zoom** tools or to enlarge or reduce the view until you can see the entire sequence range.
4) Click the **Range Selector** tool and then click on the frame 3 ORF centered on base 10,000.

![Range Selector tool](image)

Note that a large peak in the frame 3 Borodovsky graph lies entirely within this highlighted ORF. It is likely that this area represents an exon.

You are now ready to find the beginning of the potential gene.

5) In the **Top Strand…atg_2.mat** display, click and hold on the candidate start site at the far left end of the ORF. This site is shown enlarged below.

![Top Strand...atg_2.mat display](image)

- The header shows the position of the candidate, while the pop-up information box shows the score.
- If this is the first exon of a multi-exon gene, it must end with a donor splice site that precedes the stop codon for the ORF in the same frame. In the Top Strand…ds_2.mat display, observe that there are two candidate donor splice sites (shown circled in the following figure) beyond the Borodovsky peak and still within the corresponding frame 3 ORF.
✓ Exon 1 Donor: Base 10028; score = 4.6
✓ Exon 1 Donor: Base 10056; score = 9.6
You are now ready to annotate the first exon.

6) Select **EDIT > Go To Location**. Enter the range 9939,10055 and then click **OK**.

The position 10056 indicates the beginning of the donor splice site; therefore, the actual range of the exon extends from 9939 to 10,055.
7) Click the Annotation tool to open the Feature Editor. The location of the gene segment appears in the Segment box.

- Enter genE into the Title box.
- Enter exon1 into the Segment Name box, then click OK. A new feature is created and displayed on your assay surface.

8) Now that the first exon has been annotated, you may continue searching for additional exons.

- Any further exons must begin with an acceptor splice site, and that site should be in an ORF for which there is Borodovsky evidence for coding potential.
- Observe that the next significant Borodovsky peak is in frame 2, centered near base 10,600.
- There is one very likely acceptor candidate in the Top strand...as_2.mat display, between bases 10,207 and 10,219: Exon 2 Acceptor: Base 10,217; score = 12.0
- If there are more than two exons to this gene, Exon 2 must terminate with a donor splice site. There is a strong candidate in the Top strand...ds_2.mat display at position 10,778, some distance to the right of where the frame-2 Borodovsky peaks fall to the baseline: Exon 2 Donor: Base 10,778; score = 12.6.
- Now you may annotate this exon and join it to the first gene segment.
9) Select **EDIT > Go To Location**.

10) Enter the range **10217,10777** and then click **OK**.

11) Click the Joining Tool.

12) Select **genE - misc_feature** from the list and then click **Join**.

13) The next Borodovsky peak is not only in the same frame as exon 2, but also in the same ORF. The best candidate acceptor splice site to start exon 3 has a likelihood value of 14.1 out of a maximum 16.7—an excellent candidate. Two candidate donor splice sites are available to define the 3’ end of this exon, at 10,973 and 10,993. The first site scores higher at 6.4.

- Exon 3 Acceptor: Base 10,826; score = 14.1
- Exon 3 Donor: Base 10,973; score = 6.4

14) The next Borodovsky peak is once more in frame 2, but there is no candidate acceptor site (at the default threshold) under this peak. However, there is a site to the left of the peak, at position 11,021, that scores an impressive 15.1; this is the best candidate start for exon 4. You will note that there is no candidate donor splice site within the corresponding frame 2 ORF.

15) This indicates that Exon 4 is probably the final exon in the gene. To locate the stop codon, select **ANALYSIS>Show Available Methods** and expand **Coding Prediction – Start Stops ORFs** by clicking on the **plus sign** (Win) or the **triangle** (Mac) next to the method name.

16) Select the **Stops** method for **frame 2** and drag and drop it onto the assay surface. Notice that there is a stop codon at the end of this ORF (base 11,155). Therefore, use the splice site at base 11,021 to start this exon and the stop codon at base 11,155 to terminate this exon.

- Exon 4 Acceptor: Base 11,021; score = 15.1
- Exon 4 Donor: No likely candidates
- Stop Codon: Base 11,155

17) After locating the endpoints for Exons 3 and 4, annotate them by repeating steps 9-12 for each exon and entering the appropriate ranges.

18) Now that all four gene segments have been annotated, click on either the **Object Selector** tool or the **Range Selector** tool and then **double-click on the feature** to reopen the Feature Editor.
19) In turn, click on the coordinates for the three unnamed segments and type their names into the empty Segment Name boxes (exon2, exon3, exon4).

20) Click OK to finish. The feature should resemble the figure below:

```
+--------------------+     +--------------------+     +--------------------+     +--------------------+
| exon1              |     | exon2              |     | exon3              |     | exon4              |
```

Proceed to the next tutorial.
Corroborating predictions by BLAST search

1) Click the **Range Selector** tool and then click anywhere in the genE feature.

   **Note:** The entire sequence spanning the feature is highlighted. However, the **Selection** line in the header above the assay surface indicates that only the annotated segments of the feature are selected.

2) Select **NET SEARCH > BLAST ORF**. Leave **nr** selected in the Database drop-down menu, then click **OK**.

   - This sends the translation of the selected DNA sequence to NCBI’s BLAST server as a blastp query (protein vs. protein).
   - GeneQuest displays search results when they are returned from the server—this may take several seconds.

3) Highlight the match with Identifier **17553974** (this will likely be the first entry) and click the **Put In Document** icon.

4) In the ensuing dialog, **keep the defaults** and click **OK** to save copy of the highlighted sequence. It now appears on the assay surface under the genE feature.

   It also appears as a new **Gene Finding - Protein Finder** method at the bottom of your Method Curtain. You can apply it or remove it from the assay surface as you would any other method. This method aligns the protein sequence with the corresponding DNA region(s) in your sequence where the protein matches the sequence translation, as pictured below.

   ![Diagram of genE feature with exons](image_url)

   **Note:** Exon4 is actually 135 bp in length (range=11155-11021), but the feature obtained via BLAST searching omits the stop codon.

5) You can use the **Zoom In** tool and **click repeatedly** on the assay surface to read the sequence.

Proceed to the next section.
Checking predictions against external data

In this section, we will be comparing our results with the results the authors of this sequence obtained.

1) Select FILE > Open Entrez Sequence. Enter Z92803 in the dialog box, select the nucleotide database to search and click OK. When the Entrez result is returned, click Save to save a local copy of the sequence and open it in GeneQuest, applying the default method set.

**Note:** The Z92803 sequence is exactly the same length as your problem sequence—19,442 bases. To see all the annotations made by the authors, go to the next step.

2) In the Method Curtain for Z92803, expand the Features method. Drag the K01G5.3:CDS feature to the Assay Surface.

3) Examine the annotated gene in the region 9-12 kb. How does it match up to yours?

4) Select FILE > Save to save the project if you wish and close GeneQuest.

Further Exploration

Additional analyses

- To view a tabular summary of restriction fragments, apply one or more Enzymes - Restriction Map methods, then select SITES & FEATURES > Restriction Fragment Summary.

- GeneQuest assumes that sequences are circular unless told otherwise. To have the application treat a sequence as linear, select SITES & FEATURES > Linearize Sequence.
• To simulate multiple digestion experiments and examine fragment sizes in predicted agarose gel migration patterns, apply one or more Enzymes - Restriction Map methods, then select SITES & FEATURES > Agarose Gel Simulation. The following window opens, showing the predicted electrophoretic separation of the restriction fragments:

![Agarose Gel Simulation Diagram]

**Note:** Select a portion of sequence prior to using the following commands.

• To view tabular summaries showing method results, nucleotide composition or codon distribution, select ANALYSIS > Tabular Data, ANALYSIS > Base Composition or ANALYSIS > Codon Usage, respectively.

• To view repetitive portions of a sequence, apply one or more Repeats methods and select ANALYSIS > Repeat Summary.
• To predict how a nucleotide sequence might fold as RNA, select a <1500 bp portion of sequence and select **ANALYSIS > Fold as RNA:**

![RNA Folding](image)

**Using the microscope view**

To view the sequence for any region under the mouse pointer, click and move the pointer to a location. The microscope tool lets you stay zoomed out for the big picture, but still read the sequence.

**Changing method parameters**

Access method parameters by double-clicking on a method name or display anywhere in the GeneQuest window. Note that parameter changes made to a method in the method curtain affect all current and future displays created from that copy of the method. Similarly, parameter changes made to a display on the assay surface are applied to all displays originating from the same method in the method curtain.

To view multiple displays of a method using different parameters, add another copy of the method to the method curtain, then change method parameters separately for the added copy of the method.
Changing formatting options

**Note:** Click  and select one or more displays prior to using the following commands.

- To optimize the look of a selected display(s), select **OPTIONS > Line Color, Line Weight, Fill Pattern, or Fill Color.**

- To change the font and point size of text other than feature annotations, select **OPTIONS > Font or Size.**

Using method outlines

When you create a new assay document, GeneQuest uses a file called the default method outline (“default.dao” on Windows, “Default DNA Outline” on Macintosh) to determine which methods to place in the method curtain and which of those to apply to the assay surface. In the course of revising your assay document, you may have deleted some of the default methods, added new methods of your own, and optimized method parameters and display options. You may wish to use a similar setup in other assay documents. GeneQuest allows you to save the method outline from the current assay document and apply it to selected assay documents or to all new assay documents.

- To save the current outline as the default method outline, select **ANALYSIS > Save As Default Method Outline.**

- To save the current method outline as a file without saving it as the default, select **ANALYSIS > Save Method Outline.**

- To apply an outline from another document or saved as a separate file, select **ANALYSIS > Apply Method Outline.**

Exporting to GenVision

- To export a GeneQuest assay document as a GenVision project, select **FILE>Export as GenVision.**

- A dialog will prompt you to choose the content you wish to export: **Applied Method Displays** exports all analysis methods currently applied to your assay surface; **Selected Method Displays** exports only those analysis methods currently selected on your assay surface; **Scored ORFs** exports ORFs that correspond to a Borodovsky method applied on your assay surface for the same frame.
Protean

Overview

Protean aids you in predicting and annotating the structural character of your protein sequence and provides a graphical display and tabular summaries of sequence composition and other data. The project begins when you enter a protein sequence. The next step is to evaluate secondary structural characteristics of the polypeptide sequence by applying some of Protean’s many analysis methods to the sequence. These methods include:

- **Title**—Adds a title to the document.
- **Ruler**—Adds a ruler to the document.
- **Sequence**—Displays the sequence on the document.
- **Proteases - Protease Map**—Identifies proteolytic sites and displays them as a mini-map.
- **Patterns - Prosite Database**—Searches the Prosite database to find matches to your sequence.
- **Patterns - Ariadne File**—Locates matches between a user-specified pattern descriptor and the sequence.
- **Charge Density – Charge**—Predicts regions of positive and negative charge by summing charge over a specific range of residues.
- **Secondary Structure - Coiled Coil**—Predicts transmembrane alpha helices.
- **Secondary Structure - Garnier-Robson**—Examines the propensity of a given residue to exist in a certain structure.
- **Secondary Structure - Deléage-Roux**—Uses an independent prediction of the protein’s structural class to bias the prediction of its secondary structure.
- **Secondary Structure - Chou-Fasman**—Predicts secondary structure of proteins from the crystallographic structures of their amino acid sequences.
- **Hydropathy - Goldman-Engleman-Steitz**—Predicts non-polar alpha helices which may span a cell membrane.
- **Hydropathy - Kyte-Doolittle**—Predicts regional hydropathy of proteins from their amino acid sequences.

- **Hydropathy - Hopp-Woods**—Finds protein antigenic determinants by searching protein sequences for the area of greatest local hydrophilicity.

- **Antigenicity - Sette MHC Motifs**—Predicts peptide antigenic sites which interact with mouse MHC II haplotype d proteins.

- **Antigenicity – AMPHI**—Predicts immunodominant helper T-lymphocyte antigenic sites from primary sequence data.

- **Antigenicity - Rothbard-Taylor**—Locates potential T-lymphocyte antigenic determinants which contain a common sequence motif.

- **Antigenicity - Jameson-Wolf**—Predicts potential antigenic determinants by combining existing methods for protein structural predictions.

- **Amphiphilicity – Eisenberg**—Predicts the Eisenberg Moment.

- **Surface Probability – Emini**—Predicts the probability that a given region lies on the surface of a protein.

- **Flexibility - Karplus-Schulz**—Predicts backbone chain flexibility.

- **Post-Translational - Sumoylation**—predicts sites that undergo the addition of small, ubiquitin-like modifiers after translation.

- **Features**—Not a true “method,” but a list of known features for the sequence.

Once the methods have been applied, the results are displayed graphically on a common horizontal scale. In addition, menu commands let you display tabular data summaries, calculate titration curves, create protease digestion maps, and perform SDS PAGE simulations.

Protean reads and interprets GenBank-formatted features from the comment or features pane of sequence documents. Furthermore, you may create your own annotations for features of interest and even link several features together under a common title and description.

You can also use Protean to create images for publication. You can juxtapose and superimpose method results graphically or utilize one of Protean’s tabular data summaries. You may also wish to take advantage of Protean’s specialized protein fonts, which allow you to view sequences as chemical formulas or space-filling models.
10 Quick-Start Steps for Using Protean

Here are ten basic steps for using Protean:

1) Create a new project (FILE>New) or open an existing project (FILE>Open) and review the results of the current method outline.

2) Select ANALYSIS > Show/Hide Available Methods to display a list of methods, and select which of these you would like to apply to the sequence.

3) Move the methods you want from the More Methods menu to the Method Curtain. Apply methods to the sequence by using the mouse to drag them from the Method Curtain to the assay surface. Continue to add, delete or rearrange method displays until you are satisfied with the look of the document.

4) View the results in tabular form, if desired.

5) Edit method parameters at any time, either by double-clicking on the method display or on the method name in the Method Curtain. The method display is updated after each edit.

6) Use the graphical and tabular results to form hypotheses about your sequence, and then annotate any interesting features.

7) If you wish, create a structural model of your protein, or calculate its titration curve.

8) If you have applied proteolytic digestion methods to the sequence, you may run a SITES & FEATURES > SDS Page Gel Simulation.

9) Search BLAST or Entrez databases for matches to your sequence, or other sequences of interest.

10) FILE > Save your results, FILE > Print them, if desired, and quit using FILE > Exit (Win) or PROTEAN > Quit Protean (Mac).

Protean Tutorials

The tutorials in this chapter should be followed in order, as they are designed to walk you through an example Protean project from start to finish. The Further Exploration section at the end of the chapter highlights optional features you may wish to use as you gain experience with the software.
Correlating annotations with predicted structures

Objective: To open an existing protein assay and to view the locations of known calcium-binding sites and correlate them with predicted turns.

The data for this tutorial can be found in the following location:

- **Windows Vista/Windows 7:** C:\Users\Public\Public Documents\DNASTAR\Lasergene 9 Data\Demo Data
- **Windows XP:** C:\Documents and Settings\All Users\Shared Documents\DNASTAR\Lasergene 9 Data\Demo Data
- **Macintosh OSX:** Hard Drive:Applications:DNASTAR:Lasergene 9 Data:Demo Data

1) Launch Protean.

2) Select **FILE > Open** to open Human Calmodulin.pad from the **Demo Data** folder. Protean opens the project in a new window.

Several analytical method displays are already present on the **Assay Surface**, the main area of the Protean window. These methods are listed on the right side of the figure above.

This figure displays the **Method Curtain**, open at the left. The Method Curtain contains methods that can be applied to the assay surface using a drag and drop method.
3) In the Method Curtain, click on the **triangle** (Mac) or the **plus sign** (Win) to the left of the method **Features** to reveal a list of annotations that were imported with the sequence. If the items in the list appear highlighted, click in the white space to their left to ungroup them.

4) Sort the features by name using the command **CHOOSE SITES & FEATURES > Sort Features > Name**.

5) Using **Ctrl+click** (Win) or **Cmd+click** (Mac) highlight each of the four features named **Calcium binding region:Region**. If you cannot see the complete names of the features in the Method Curtain, widen it by dragging the curtain pull (くださやげ） to the right.

6) Drag the highlighted features to the right and drop them on the assay surface. The four features now appear on the assay surface and remain selected.

7) Select **OPTIONS > Superimpose Objects** to place all four calcium binding site locations (represented by cylinders) on the same line.

When you have predicted structures and features displayed in this way, you can begin to evaluate the structural characteristics of the protein and its corresponding features.

8) To make it easy to compare the calcium-binding site locations with predicted turns, scroll to the far right of the assay surface, select the name **Turn, Regions - Garnier-Robson** from the list, and drag it down to be just above the calcium binding site display name.
Note that the calcium binding sites are all located in predicted turn regions. This is consistent with the known structure of these binding sites, which are classical “EF Hand” calcium-binding sites wherein calcium is bound at the “elbow” between two adjacent alpha-helical regions.

Proceed to the next tutorial.

**Calculating methods with different parameters**

You can access method parameters by double-clicking on a method name or display anywhere in the Protean window. Note that parameter changes made to a method in the Method Curtain affect all current and future method displays created from that copy of the method. Similarly, parameter changes made to a display on the assay surface are applied to all displays originating from the same parent method in the method curtain. To view multiple displays of a method using different parameters, therefore, you can add a second (or third, etc.) copy of the method to the Method Curtain, then change method parameters separately for the added copy of the method.

**Objective:** To apply a new **Hydropathy – Kyte-Doolittle** method to the sequence, to change its parameters, and to compare it to the already applied **Hydropathy – Kyte-Doolittle** method.

1) Click **More Methods** at the top of the Method Curtain to open a menu containing methods. From this menu, you can select methods that aren’t listed in the lower part of the method curtain or make additional copies of methods that are.

2) Select **Hydropathy – Kyte-Doolittle**. A new copy of the method now appears at the top of the method curtain list.

3) Now that the method is in the main body of the method curtain, it may be applied to the sequence. Click on the **plus sign** (Win) or the **triangle** (Mac) to the left of one of the Hydropathy – Kyte-Doolittle methods to reveal the four possible display types, shown below. If the items in the list appear highlighted, click in the white space to their left to ungroup them.
4) Click on **Hydrophilicity Plot**, drag it to the assay surface and drop it below the existing **Hydrophilicity Plot – Kyte-Doolittle** display.

- Predicted hydrophilic regions of your protein are shown as a black and white graph in the new method.

5) Double-click on the newly added display to open its method parameter dialog.

6) Change the **Residues to Average** to 3 and click **OK**.

- The original display used the default value of 9.
- The two displays now show the effects of applying the different parameter values:

![Graph comparison]

Proceed to the next tutorial.

**Predicting proteolytic cleavage sites and performing SDS PAGE simulations**

**Objectives:** To identify and display proteolytic sites, then to simulate an SDS PAGE run.

1) From **More Methods** at the top of the Method Curtain, select **Proteases – Protease Map**.

2) View the following information about the available proteases by choosing **SITES & FEATURES > Show Protease List**.

![Protease List]
3) When you are finished, select FILE > Close to close the Protease List.

4) Click on the plus sign (Win) or the triangle (Mac) to the left of Proteases - Protease Map method name to view the list of proteases. If the items on the list appear highlighted, click in the white space to their left to ungroup them.

5) Use Ctrl+click (Win) or Cmd+click (Mac) to highlight both Chymotrypsin and CNBr, and then drag them onto the assay surface. The resulting method displays show recognition sites as vertical bars.

6) Leaving the displays highlighted, select SITES & FEATURES > SDS PAGE Gel Simulation. An image of the simulated separation will appear in a new window. Above each column in the gel is the name of the corresponding protease or molecular weight standard.

7) Move your cursor over the surface of the gel and notice how the header at the top of the window changes. When the cursor is over a protease fragment (CHYM or CNBR), the header displays its molecular weight, sequence range, HPLC retention time and predicted pI.
8) Select **SITES & FEATURES > Protease Fragment Summary**. This opens a summary of information about the proteases applied to the sequence.

<table>
<thead>
<tr>
<th>Chymotrypsin - 30 cuts</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>149.20</td>
</tr>
<tr>
<td>2</td>
<td>445.46</td>
</tr>
<tr>
<td>6</td>
<td>996.00</td>
</tr>
<tr>
<td>14</td>
<td>493.54</td>
</tr>
<tr>
<td>16</td>
<td>216.24</td>
</tr>
<tr>
<td>25</td>
<td>1</td>
</tr>
<tr>
<td>21</td>
<td>13</td>
</tr>
<tr>
<td>34</td>
<td>4</td>
</tr>
<tr>
<td>36</td>
<td>3</td>
</tr>
<tr>
<td>41</td>
<td>9</td>
</tr>
<tr>
<td>56</td>
<td>3</td>
</tr>
<tr>
<td>53</td>
<td>14</td>
</tr>
<tr>
<td>67</td>
<td>3</td>
</tr>
<tr>
<td>76</td>
<td>1</td>
</tr>
<tr>
<td>71</td>
<td>2</td>
</tr>
<tr>
<td>73</td>
<td>1</td>
</tr>
<tr>
<td>74</td>
<td>4</td>
</tr>
<tr>
<td>76</td>
<td>10</td>
</tr>
<tr>
<td>91</td>
<td>3</td>
</tr>
<tr>
<td>94</td>
<td>7</td>
</tr>
<tr>
<td>101</td>
<td>6</td>
</tr>
<tr>
<td>107</td>
<td>2</td>
</tr>
<tr>
<td>105</td>
<td>2</td>
</tr>
<tr>
<td>111</td>
<td>3</td>
</tr>
<tr>
<td>114</td>
<td>3</td>
</tr>
<tr>
<td>118</td>
<td>6</td>
</tr>
<tr>
<td>126</td>
<td>14</td>
</tr>
<tr>
<td>146</td>
<td>3</td>
</tr>
<tr>
<td>142</td>
<td>3</td>
</tr>
<tr>
<td>146</td>
<td>1</td>
</tr>
<tr>
<td>147</td>
<td>3</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Others - 10 cuts</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>149.20</td>
</tr>
<tr>
<td>2</td>
<td>39</td>
</tr>
<tr>
<td>28</td>
<td>15</td>
</tr>
<tr>
<td>50</td>
<td>20</td>
</tr>
<tr>
<td>73</td>
<td>1</td>
</tr>
<tr>
<td>74</td>
<td>4</td>
</tr>
<tr>
<td>76</td>
<td>33</td>
</tr>
<tr>
<td>111</td>
<td>15</td>
</tr>
<tr>
<td>126</td>
<td>20</td>
</tr>
<tr>
<td>146</td>
<td>1</td>
</tr>
<tr>
<td>147</td>
<td>3</td>
</tr>
</tbody>
</table>
Further Exploration

Additional analyses

- To view tabular summaries of method results and sequence composition, select **ANALYSIS > Tabular Data** or **Composition**.

- To view the secondary structure of the sequence, select **ANALYSIS > Model Structure** and select from **Helical Wheel**, **Helical Net**, **Beta Net**, **Linear Space Fill** or **Chemical Formula**. A helical wheel structure is shown below:
To view a titration curve like the one below, select **ANALYSIS > Titration Curve**:

![Titration Curve](image)

**Using method outlines**

When you create a new assay document, Protean uses a file called the default method outline ("default.pao" on Windows, “Default Outline” on Macintosh) to determine which methods to place in the method curtain and which of those to apply to the assay surface. In the course of revising your assay document, you may have deleted some of the default methods, added new methods of your own, and optimized method parameters and display options. You may want to use the same setup or a similar setup in other assay documents, as well. Protean allows you to save the method outline from the current assay document and apply it to selected assay documents or to all new assay documents.

- To save the current outline as the default method outline, select **ANALYSIS > Save As Default Method Outline**.
- To save the current method outline as a file without saving it as the default, select **ANALYSIS > Save Method Outline**.
- To apply an outline from another document or saved as a separate file, select **ANALYSIS > Apply Method Outline**.
Using the microscope view

To view the sequence for any region under the mouse pointer, activate (the Microscope palette tool) and move the mouse pointer to the desired location. The microscope tool lets you stay zoomed out for the “big picture,” but still read the sequence.

Exporting to GenVision

- To export a Protean assay document as a GenVision project, select FILE>Export as GenVision.

- A dialog will prompt you to choose the content you wish to export: Applied Method Displays exports all analysis methods currently applied to your assay surface; Selected Method Displays exports only those analysis methods currently selected on your assay surface.
Protean 3D

Overview

A component of DNASTAR’s Lasergene suite, Protean 3D is an integrated visualization tool designed for the needs of today’s molecular biologists and geneticists. With Protean 3D’s user-friendly interface, you can explore macromolecular structure and function with ease.

Protean 3D gives you the ability to work with a protein sequence and its molecular structure simultaneously on one screen. Structural features such as binding sites, disulfide bonds, helices and beta-sheets are color-coded for effortless identification. You can zoom in, move or rotate the structure image, change its rendering, turn on and off the display of structural components or features, and re-color items of interest. One of Protean 3D’s highlights is its ability to synchronize the selection made in one view with all other views.

In addition to supporting files for protein, DNA, RNA and small molecules, Protean 3D features a built-in Motion Library of approximately 300 animated sequences adapted from Yale Morph Server files. The Library’s movie files contain many instances of the same structure in slightly different conformations. With Protean 3D, you can view these as animations, individual structures, or overlapping models.

10 Quick-Start Steps for Using Protean 3D

1) Launch Protean 3D and use FILE > Open to open a structure file (e.g. from the Protein Data Bank).

2) Select one of the first four toolbar icons ( ), then use your mouse to rotate, move, or zoom in/out on the structure.

3) Use the Structure and Features expand bars to show, hide or select various structural components and features.
Note: If a panel or expand bar is not visible, you can reveal it using the corresponding command from the View menu. To open a closed expand bar, or vice versa, click on the bar bearing its name.

4) Customize the Structure View by using the Color expand bar to change the color of the background or of any selection. Selections can be made from the Structure and Sequence Views or the Structure and Features bars, and are synchronized between all views.

5) Use the Rendering expand bar to change the way the backbone, side chains and ligands are drawn.

6) Customize the Sequence View using the Sequence expand bar.

7) If you are working with a multi-model NMR structure file, use the Models panel to overlay models. If you are working with a movie file from the Motion Library, use the same panel to control the animation speed and to pause/play the animation.

8) Use FILE > Save to save the Protean 3D document.

9) Use FILE > Export Image to export graphics. You may also export multi-model files as animated GIFs.

10) Use FILE > Exit (Win) or PROTEAN 3D > Quit (Mac) to exit Protean 3D.

Protean 3D Tutorials

The tutorials in this chapter should be followed in order, as they are designed to walk you through an example Protean 3D project from start to finish. During this workflow, observe that any selections you make in a panel or view are simultaneously highlighted in the Structure View and Sequence View.

Downloading a file from the Protein Data Bank

Most of the following Protean 3D tutorials use a PDB structure file named 7TIM. This tutorial demonstrates how to locate and download this file from the RCSB Protein Data Bank.

Note: If you would like to skip this section, you may instead proceed to the next topic and use the 7TIM.pdb file located in your DNASTAR/Protean 3D Data folder.

To download the file from the Protein Data Bank:

1) Using your web browser, go to the Protein Data Bank home page.
2) Enter the term 7TIM into the search bar near the top of the window and click **Search**.

3) In the results page, locate the **Download Files** menu in the top right corner.

4) Click on the triangle to open the menu, and choose one of the PDB file formats (“Text” or “gz”). Once the file has been downloaded to your computer, proceed to the next tutorial.

   DNASTAR thanks the authors for the 7TIM structure file used in these tutorials:

   ![7TIM structure file](image)

   **Using the Structure View**

   This tutorial highlights usage of the toolbar and demonstrates how to make a selection in the Structure View.

   1) Launch Protean 3D.

   2) Choose **FILE > Open** and select the text file 7TIM.pdb or the zipped file 7TIM.pdb.gz that you downloaded in the previous tutorial.

   **Note:** If you skipped the previous tutorial, instead open 7TIM.pdb from your DNASTAR/Protean 3D Data folder.
3) Zoom in and out on the structure by clicking the Zoom tool ( ) and dragging the mouse up and down.

**Note:** If you don’t see the zoom icon, use the **CONTROLS > Show Toolbar** command to restore the toolbar. Another alternative is to use the commands in the **Controls** menu instead of the toolbar icons.

4) Slide the molecule partially out of view and back again by clicking the Move tool ( ) and dragging the mouse in any direction.

5) Rotate the molecule by clicking the Rotate tool ( ) and dragging the mouse in any direction.
6) Double-click on any residue in the molecule to select it. Selection is shown as a light blue highlight. De-select by double-clicking on the black background.

7) Return the structure to its original orientation by clicking on the Reset Structure View tool ( ).

**Changing the rendering of the structure**

This tutorial shows how to change the rendering of the structure backbone.

1) Open the Rendering expand bar by clicking anywhere on the bar that says “Rendering.”

**Note:** Throughout these tutorials, you may open a closed expand bar (or vice versa) by clicking on the bar bearing its name. If a panel or expand bar is not visible, reveal it by selecting the corresponding command from the View menu.
2) Select “Ribbon” from the **Backbone** drop-down menu.

The structure now appears as follows:
Using the Sequence View

This tutorial demonstrates how to make selections from the Sequence View.

1) Single-click a green spiral in the Sequence View to select it, turning it light blue. Note that the corresponding helical element also appears highlighted in the Structure View. (If you don’t see a highlighted element in the Structure View, try zooming in on the molecule or rotating it for a better view).

   ![Sequence View Image](image)

   Note: The element is also highlighted, though currently hidden from view, in the Features bar (see inset graphic).

2) Click on any red tube icon in the Sequence View to simultaneously select all residues involved in a binding site. Note that the corresponding binding site also appears highlighted in the Structure View.
Note: The element is also highlighted, though currently hidden from view, in the Features bar (see inset graphic).

Selecting and hiding a structural component

This tutorial shows how to select a particular structural element from the Structure bar.

1) Make sure that the Structure bar is open.

Notice that, by default, all boxes in the Structure bar are checked except for Water.
2) Select the first *Triosephosphate Isomerase* subunit by clicking on the letter “A” (not on its checkbox). Observe the corresponding selections in the Structure and Sequence Views.
3) Next, uncheck the box to the left of “A.” Observe that the analogous Triosephosphate Isomerase is now hidden in both Structure and Sequence Views.

4) Recheck the box so that all boxes except Water are checked.

Recoloring a feature

This tutorial demonstrates how to color a structural element and its related feature light green.

1) Maximize the Protean 3D window and open both the Structure and Features expand bars so that you can see their contents at the same time. To reveal more of the Features bar contents, you may wish to drag the Style panel downwards. You can also use the vertical scrollbar to view more of the expand bar’s contents.
2) In the Structure bar, click on the expand arrow to the left of the **Ligand PGH** checkbox to reveal \( PGH [A:249] \) and \( PGH [B:249] \).

**Note:** The expand arrow may be hidden until you hover over it with the mouse.

3) In the Features bar, click the expand arrow to the left of the **Sites** checkbox to reveal features \( AC1 \) (binding site for \( PGH A:249 \)) and \( AC2 \) (binding site for \( PGH B:249 \)).
4) Now you will select the \( B:249 \) ligand and binding site simultaneously. In the Structure bar, click on the text “PGH \([B:249]\)” to select the ligand. Hold down the **Ctrl** key (Win) or **⌘** key (Mac) and click on the text “AC2” to select the related binding site.

5) To color the site and feature, open the Color bar. You may need to close the Rendering bar first, depending on the size of your Protean 3D window. In the Color bar, click on the box under the word **Fill** to open the color picker for your operating system.
On Windows, choose any shade of light green and click **OK** to close the window and return to Protean 3D. On Macintosh, you must close the color picker after selecting the light green color.

6) In the Structure View, the selection initially remains highlighted in blue. De-select it by double-clicking on the black background. The *AC2* ligand and the associated binding site now appear light green.
Working with a multi-model file

This tutorial shows how to open and work with a multi-model file from the Motion Library.

1) Choose **FILE > Open from Motion Library** to open the floating Motion Library window.

2) In the Find bar, enter *isocitrate* and click **Search**. One match will be shown. Notice that the animated thumbnails that did not match the search term are now hidden.

3) The panel on the right displays detailed information about the first and last models in the animation. Hyperlinks lead to additional data about the molecule in the PDB, CATH, and GO databases.

![Motion Library window](image)

Double-click on the thumbnail to open the animation as a new document. If you have not previously downloaded the Motion Library, you will be prompted to download the file you selected:
Check the **Remember my decision** box if you would like to download individual Motion Library files in the future without being prompted. Then click **Download file**.

4) In the Models panel, move the slider to the left to slow the animation.
5) Click the **Pause** button ( ) to stop the animation. The **Model** last displayed in the Structure View as a “movie frame” remains checked and in view.

6) Check a second **Model** box to overlay the two models in the Structure View.
Overlays are helpful for checking where multiple models in NMR files agree and disagree. They can also be used as presentation graphics to show the path of motion in a movie file.

Further Exploration

You can perform the same tasks with multi-model files as you did in earlier tutorials with the single-model file 7TIM, including selecting, recoloring or hiding various structural elements and features, and changing the structure rendering.
PrimerSelect

Overview

PrimerSelect helps you design primers and probes for PCR, sequencing, and hybridization experiments.

The project begins when you enter a template sequence from any of a wide variety of sequence files or from NCBI’s BLAST or Entrez databases. If a sequence file is longer than you need, you may specify a portion of the sequence by coordinates or by selecting a feature from the feature table.

Sequences added to a project are arranged in the Document Window, the principle working area in PrimerSelect. The Document Window is used to collect and inspect template sequences and to evaluate search results. The window has five views, which display templates, primers and products. Once you have entered one or more template sequences, PrimerSelect processes the template for melting temperatures, free energy, and terminal free energy in pentamer windows. These primary calculations are all controlled by initial conditions that you set yourself.

After template processing, PrimerSelect identifies and scores primers based on your specified criteria. Primer “Workbenches” allow you to modify your primer and see how any edits affect translated reading frames, secondary structure, false priming sites and restriction sites. Once you have selected and optimized your primer, PrimerSelect lets you create documents recording the theoretical activity of the templates, primers, and amplification products.

10 Quick-Start Steps for using PrimerSelect

Here are ten basic steps for using PrimerSelect:

1) Select FILE > New to create a new project or FILE > Open to open a previously saved project. To reopen a document that has recently been opened in PrimerSelect, select it from the FILE > Recent Documents list.

2) Add one or more template sequences to the Document Window using FILE>Enter Sequence.

3) Define your starting conditions and desired primer characteristics by using the options on the CONDITIONS menu.
4) If desired, save your conditions and primer characteristic settings for use with other template sequences using **CONDITIONS > Save Conditions**.

5) Let PrimerSelect choose primers for you by using **LOCATE > Primers & Probes**, or enter your own primers. To use only those primers in the catalog, select **LOCATE > Only Catalogued Primers**. Sort the resulting primers, if desired, by using **LOCATE > Sort Primers**.

6) Search for primer pairs by using **LOCATE > PCR Primer Pairs**. Select **LOCATE > Adjust Scoring** to change the weight of such factors as internal stability and product length.

7) View results in tabular form by going to the **REPORT** menu and choosing Amplification Summary, Composition Summary, Primer Self Dimers, Primer Pair Dimers, or Primer Hairpins.

8) Activate a primer pair in the Located Primer Pairs window by double clicking on it.

9) Make any necessary modification to the active primers using the Workbenches accessed from the **EDIT** menu. The mutated primers can then be saved in the primer catalog.

10) **FILE > Save** your results, if desired, then **FILE > Exit** (Win) or **PRIMERSELECT > Quit PrimerSelect** (Mac) to exit PrimerSelect.

---

**PrimerSelect Tutorials**

The tutorials in this chapter should be followed in order, as they are designed to walk you through an example PrimerSelect project from start to finish. The Further Exploration section at the end of the chapter highlights optional features you may wish to use as you gain experience with the software.

**Defining primer design criteria**

**Objective**: To specify primer characteristics and their locations using the cloning vector pBR322 as the template sequence.

The data for this tutorial can be found in the following location:

- **Windows Vista/Windows 7**: C:\Users\Public\Public Documents\DNASTAR\Lasergene 9 Data\Demo Data
- **Windows XP**: C:\Documents and Settings\All Users\Shared Documents\DNASTAR\Lasergene 9 Data\Demo Data
- **Macintosh OSX**: Hard Drive:Applications:DNASTAR:Lasergene 9 Data:Demo Data
1) Launch PrimerSelect.

2) Select **FILE > Enter Sequence** and highlight **pbr322.seq** from the **Demo Data** folder.

3) Click **Add** (Win) or **Add File** (Mac) to move the sequence into the Selected Sequences/Chosen Files list.

4) Click **Done** to open the selected sequence in PrimerSelect’s Document Window. The window should appear as follows:

5) Select **CONDITIONS > Primer Characteristics** to open the dialog below.

   The default primer length has been set to 17-24 bp, and that dimer and hairpin duplexing of 1 or 2 bp will be accepted.

6) Leave the default settings and click **Cancel** to exit the dialog.
7) Select **CONDITIONS > Primer Locations** to open a dialog for restricting primer locations based on a given product length, a range in the template, or a combination of both.

![Primer Locations Dialog](image)

8) From the **Restrict Locations By** list, select **Upper and Lower Primer Ranges**. Text boxes appear to permit you to define these numbers.

   This is the best choice when designing PCR primers for a particular region of a sequence.

9) In Upper Primer Locations, enter **1700** and **1950** respectively.

10) In Lower Primer Locations enter **2250** and **2500** respectively.

11) Click **OK** to return to the Document Window, which now appears as follows. Paired green and red triangles mark the allowable ranges for the upper and lower primers, respectively.

![Document Window](image)

Proceed to the next tutorial.
Searching for primer pairs

Objective: To search automatically for the best primer pairs.

1) Select LOCATE > PCR Primer Pairs. The Located Primer Pairs window appears, displaying a list of primer pair candidates, with the best choices shown at the top of the window.

![Located Primer Pairs window](image)

The upper pane of the Located Primer Pairs window shows the principle list of primer pairs. Because (the Alternate Pairs palette tool) is active by default, the lower pane currently shows a list of alternatives for the pair currently selected in the top pane.

2) Open the advice curtain on the right side of the window by dragging (in the upper right corner) towards the left. PrimerSelect’s advice about each of the primer pairs now appears in the right column of the window, as shown below.

PrimerSelect ranked these primer pairs based on criteria established in the Initial Conditions, Primer Characteristics and Primer Locations dialogs located under the CONDITIONS menu. Note that the top pair is annotated as the “Best choice.”
3) Double-click the primer pair at the top of the window to make it active.

4) Click ![Show Alternate Products palette tool](image) to change the lower pane into a display showing intended and false primer sites and potential products for the highlighted primer pair.

5) Click each successive primer pair in the top pane and observe how the product bar in the lower pane becomes thinner, denoting a decrease in the amount of product expected. Note that some of the primer pairs have false primer sites, indicated by pink or light green arrows, and possible secondary products, denoted by dotted lines:

Proceed to the next tutorial.
Viewing composition and hairpin reports

Objective: To view reports showing the composition of the primers and information about possible hairpins.

1) Double-click the primer pair at the top of the window.

2) Select REPORT > Composition Summary to view the following table describing the composition of the primer pairs.

<table>
<thead>
<tr>
<th>Product</th>
<th>Upper Primer</th>
<th>Lower Primer</th>
</tr>
</thead>
<tbody>
<tr>
<td>Single Strand Mr</td>
<td>73.9 k</td>
<td>78.0 k</td>
</tr>
<tr>
<td>Exclusion Coefficient 1/E</td>
<td>0.174 kM/200</td>
<td>0.174 kM/200</td>
</tr>
<tr>
<td>Length</td>
<td>167 bp</td>
<td>127 bp</td>
</tr>
<tr>
<td>Tm (1°C Method)</td>
<td>81.3°C</td>
<td>0°C</td>
</tr>
<tr>
<td>Tm at 6xG6C</td>
<td>120.9°C</td>
<td>27°C</td>
</tr>
<tr>
<td>G+C Content</td>
<td>54.9%</td>
<td>54.9%</td>
</tr>
</tbody>
</table>

Other commands in the REPORT menu let you view self-dimers and pair dimers.

3) Select REPORT > Primer Hairpins to view predicted primer hairpin structures in a window like the one below.

Other commands in the REPORT menu let you view self-dimers and pair dimers.

4) When you are done viewing these windows, close them before continuing with the next tutorial. Leave the Located Primer Pairs and main PrimerSelect window (“Untitled”) open.

Proceed to the next tutorial.
Changing primer length

Objective: To extend the length of a primer using the Upper Primer Workbench.

1) With the top primer pair active, select **EDIT > Work on Upper Primer** to open the Upper Primer Workbench shown below.

The palette tools (Show sites), (Show reading frames), (Show self-dimers), (Show primer hairpins) and (Show false priming sites) are active by default. The (Site filter tool) may also be used if desired.

About a third of the way down the Workbench, the primer sequence is shown in black. The triangular “handles” at either end allow you to shorten or lengthen the sequence.

![Upper Primer Workbench](image)

2) Click on the primer sequence in black.

- The header in the upper left corner of the window now shows that the primer is 24 nucleotides long and has a melting temperature of 66.3°C, while a ruler near the bottom of the window shows the single possible annealing site as a short green bar.

- Below the ruler are messages showing that there are no dimers larger than 2 bp, and that the primer is able to form only one, energetically unfavorable 2 bp hairpin.
3) Click the black triangle on the right side of the primer sequence and drag it one base to the left so that the length is shortened to 23 nucleotides. Then, click the black triangle on the left side of the primer sequence and drag it to the left until the length has been extended to 31 nucleotides. Check the length in the header, adjusting as necessary until your header matches the one in the figure below. The header also shows that the melting temperature for the primer has increased to 77.8°C.

![Primer sequence with modified length](image)

Looking at the lower part of the window, note the new, energetically favorable dimers that PrimerSelect has labeled with the warning “BAD!” Such primers may not amplify the region you want efficiently.

### Introducing a primer mutation

If desired, you can modify a primer simply by clicking on any base and typing. This tutorial, however, presents a more “structured” method for modifying a primer.

**Objective:** To improve the undesirable extended primer while keeping its sequence relatively unchanged. This will be accomplished by changing a Glycine residue to Serine.

1) Click the **Glycine (Gly) residue** in frame 2, written in green just below the primer. A menu appears, showing all four possible Glycine codons and the word Other. The check mark shows that GGT is the triplet encoding this particular Glycine residue.

2) Select **Other** to open a menu with a list of amino acids.

3) Click **S - Serine.**

   - The Gly code in the original line of green text does not change, but the duplicate sequence that appears below it in black now shows Ser where the Gly used to be. Ser appears in red to show that it is a mutation from the original primer sequence.

   - Looking at the bottom of the screen, note that the two “BAD!” dimers have been replaced by one unfavorable hairpin.
4) Click the **Ser** residue and select **AGT** from the menu that appears.

- This makes a silent mutation to the Ser residue by changing the triplet that codes for Serine from TCT to AGT.
- The original Ser residue had two substitutions compared to the original extended primer (TCT vs. GGT), but now the residues differ by only a single nucleotide.
- The melting temperature has now been reduced to 63.3°C, which is very close to the melting temperature of the original 24 bp primer (66.3°C).

5) In the **Name** field at the bottom of the workbench, enter “Mutant Upper Primer”.

6) Click **OK** to save the mutant primer.

Proceed to the next tutorial.

**Creating a new primer**

**Objective**: To create a new primer using the “mutated primer” sequence as a foundation within the Primer Catalog.

1) Select **LOG > Primer Catalog** to open the primer catalog for the current project.

![Primer Catalog](image)

Note that the mutated upper primer created in the last tutorial is already present in the catalog. To the left of the primer is a checkmark identifying it as active, and a chevron (>>, Windows) or bullet (•, Macintosh) showing that it has passed initial secondary structure tests.

2) Double-click in the Sequence field to make it active.

3) Highlight the sequence.

4) Select **EDIT > Copy**.

5) Press Return/Enter to create a line for entering a new primer. The new Sequence field will automatically be active. Select **EDIT > Paste** to paste in the sequence you just copied.

6) Place the cursor at the end of the sequence and type ACGT.

7) Press the **Tab** key to enter a comment into the Note field.
8) Double-click in the Name field to activate it, and then type in a name.

9) Close the Primer Catalog window to finish. The new primer is now added to the catalog. You can limit future primer searches to only those primers in the catalog (LOCATE>Only Catalogued Primers), which is a useful way to evaluate whether primers you already have may be useful in a particular experiment.

---

**Further Exploration**

### Sorting primers by characteristic

When you select LOCATE > Primers & Probes, PrimerSelect considers all of the desired primer characteristics before sorting primers in the Located Primer Pairs window from best to worst. To re-sort primers according to a particular characteristic, such as melting temperature, select LOCATE > Sort Primers. After using this command, the Located Primers & Probes window sorts the list of primers according to the specified criteria.

### Selecting a primer pair

To retain information about multiple primer pairs found along the template sequence, you may place your favorite primers in a special list. To add a primer pair to the list, select it from the Located Primer Pairs window and select LOCATE > Choose This Pair. To open the list, select LOG > Selected Primer Pairs. The current pair, whose amplified products are displayed beneath the template sequence in the Block View, is indicated by a check mark. To remove the check mark without discarding a pair from the list, simply click on it. Click elsewhere to make a new pair active. To discard a pair, select it and press Backspace (Win) or Delete (Mac).

### Using only catalogued primers

To perform a Primers & Probes search using only primers in the Primer Catalog, select LOCATE > Only Catalogued Primers.

**Note:** Close any open PrimerSelect projects and begin afresh before using this command. Otherwise, the results will be combined with the results of any previous Primers & Probes search.
EditSeq

Overview

EditSeq is provided with every Lasergene system to enable you to work on nucleic acid and protein sequences of all sizes from a variety of formats, including GenBank, FASTA, MacVector, GCG®, Text, ABI®, and data from the clipboard. You can even access NCBI's databases by accession number or utilizing the integrated Internet interface to search BLAST and Entrez text databases.

With EditSeq you can manually edit sequence, comments, and annotations, conveniently separated into three adjustable and editable panes. Dynamic links between sequence and annotations exhibit automatic updating of feature coordinates with sequence editing and inclusion of features with copying/pasting of sequences. You can trim a long sequence by specifying a portion of the sequence by coordinates.

EditSeq’s search functions let you find positions and open reading frames instantly. You can complement, reverse complement, or view statistics about any sequence or portion of a sequence. You may also translate a DNA sequence or back-translate a protein sequence using customized, expression-specific genetic codes.

A sequence saved using EditSeq in Lasergene DNA or protein sequence format may be opened by any other Lasergene application.

10 Quick-Start Steps for Using EditSeq

Here are ten basic steps for using EditSeq:

1) Create a new EditSeq document (FILE>New) or open/import an existing sequence file (FILE>Open or FILE>Import).

2) Enter or edit data into the Sequence Pane and Comments Pane by typing, or by using options from the EDIT menu.

3) Format the document as desired by using the EDIT menu.

4) Use the SEARCH menu to locate ORFs, specific sequence strings, or to move the cursor to a numerical position or line.
5) Proofread the sequence using tones or a speech synthesizer by selecting options from the **SPEECH** menu.

6) Use the **GOODIES** menu to open a new sequence window containing the complement or inverse of a highlighted portion of sequence. You may also translate a DNA sequence or reverse translate a protein sequence.

7) Use the **GOODIES** menu to view DNA statistics or protein statistics for any highlighted portion of a sequence.

8) Create or edit feature annotations using the **FEATURES** menu.

9) Search online for additional sequences using the **NET SEARCH** menu.

10) Save the sequence document (**FILE>Save**) or export the sequence as a Genbank Flat File, FastA file, or GCG® file (**FILE>Export**).

---

**EditSeq Tutorials**

The tutorials in this chapter should be followed in order, as they are designed to walk you through an example EditSeq project from start to finish. The Further Exploration section at the end of the chapter highlights optional features you may wish to use as you gain experience with the software.

**Opening a subset of a sequence**

All Lasergene applications allow you to utilize a subset of a sequence if so desired.

**Objective:** To open a portion of an existing sequence file.

The data for this tutorial can be found in the following location:

- **Windows Vista/Windows 7:** C:\Users\Public\Public Documents\DNASTAR\Lasergene 9 Data\Demo Data
- **Windows XP:** C:\Documents and Settings\All Users\Shared Documents\DNASTAR\Lasergene 9 Data\Demo Data
- **Macintosh OSX:** Hard Drive:Applications:DNASTAR:Lasergene 9 Data:Demo Data

1) Launch EditSeq.

2) Select **FILE > Open.**
3) Locate Tethis21.seq from the **Demo Data** folder.

4) Click on the sequence to highlight it. Single-clicking a sequence lets you use the Set Ends feature and also causes sequence information to be displayed in the lower half of the dialog. Note that the sequence length is 906 bp.

5) From the Open dialog, click **Set Ends**.

6) Type 50 and 850 into the 5’ and 3’ end boxes, as shown below.

![Set Ends dialog](image)

Length: 906 bp  
Range: 801 bp

7) Click **OK** to return to the Open dialog. Note that the sequence range is now 801 bp.

8) Click **Open** to open the sequence in EditSeq.

![EditSeq window](image)

The upper right corner of the header shows that 801 bp of the original sequence has been opened in the upper pane of the window.
The top pane contains the sequence, the middle pane contains the sequence comments, and the bottom pane lists the features (annotations) included in the 50-850 bp range of the original sequence.

Proceed to the next tutorial.

**Locating open reading frames**

**Objectives:** To locate potential ORFs.

1) Select **SEARCH > Find ORF**. The Search DNA dialog appears.

2) Click **Find Next** to close the dialog and locate the first ORF. EditSeq locates and highlights the first ORF in the Sequence Pane. The coordinates for the highlighted ORF appear in the EditSeq header.

3) Click **Find Next** at the bottom left of the EditSeq window until you have located and highlighted the ORF at position 345-455.

Proceed to the next tutorial.

**Adding a feature with a translation**

Features are annotations that document points of interest in the sequence. The current sequence already contains features, which can be viewed in the Features Pane at the bottom of the EditSeq window. EditSeq also lets you add your own features to a sequence.

**Objectives:** Create a new feature and an associated translation for a segment of the sequence, then update an obsolete translation.

1) With bases 345-455 still highlighted, select **FEATURES > New Feature with Translation**. The new feature and translation appear at the bottom of the Features Pane (the bottom pane in the EditSeq window).

```
CDS
345..455

/NOTE=""

/TRANSLATION="MNIMN8FINDS8F8RIALES8SKLVPRNKRRTLS8REV."
```
2) Assume that this portion of the sequence is an exon of interest. Click on the box marked **CDS** at the beginning of the feature description to view the feature name options.

3) Select **GENE > Exon**.

4) Click directly on the word **/note** to display a menu of alternative qualifiers and choose **/function** from the list.

5) Insert the cursor between the quotation marks following the “/function” field. Type a note about the feature if you wish. (In the example below, we’ve typed “histone binding region”). Click anywhere outside the note area to complete the procedure.

6) Double-click anywhere in the Sequence Pane between bases 345-455 to insert your cursor and then type three random bases. The translation in the new feature turns red to notify you that changes have been made to the sequence. The translation is now obsolete.

7) Select **FEATURES > Update Translation** or **FEATURES > Update All Translations** to update the feature translation. After updating, the translation will again appear black.

Proceed to the next tutorial.
Copying and translating sequences

Objective: To copy the ORF and its associated feature into a new EditSeq document, then to translate the ORF.

1) Highlight the modified ORF, which now runs from 345-458, by double-clicking anywhere on that feature in the Feature Pane.

2) Copy the ORF using EDIT > Copy.

3) Create a blank EditSeq document by selecting FILE > New > New DNA.

4) Paste the ORF into the blank document using EDIT > Paste.

   Note that the feature you created earlier has also been pasted into the document. When you copy and paste sequence, features wholly included in the copied portion are also included. Features only partially included in the copied sequence are excluded.

5) Select the ORF using EDIT > Select All.

6) Select GOODIES > Translate DNA to translate the sequence in a new protein sequence window.

   The lower pane of the translation window displays statistics about the translated sequence. Note that in the graphic above, the number of amino acids listed by category do not add up to the total number of amino acids (7+4+12+11≠36). That’s because the four categories are not comprehensive and do not include such items as non-polar amino acids.
7) Close all open EditSeq windows by selecting **FILE > Close**. When prompted to save the document, click **No** (Win) or **Don’t Save** (Mac).

---

**Further Exploration**

**Importing and exporting sequences**

- To open a sequence file created with an outside software program, use drag and drop or select **FILE > Import**.
- To save a sequence as a GenBank Flat File, FastA file or GCG file, use **FILE > Export**.
- To save all open windows of a particular type (DNA or protein) into a single file having a GenBank Flat File, FastA file or DNA Multi-seq file format, select **FILE > Export All As One**.

**Changing layout options**

- To optimize fonts, sizes and cases select **EDIT > Font, Size, To Uppercase, To Lowercase, or Reverse Case**.
- To make a sequence easier to read, group it into blocks using **EDIT > Layout**.
- To display amino acids using their three-letter code designations, select **EDIT > Use 3 Letter Codes**.

**Proofreading a sequence**

- To listen to a sequence as you type, or to playback a sequence that has already been entered, select **SPEECH > Proofread Sequence**.
- To hear the sequence read via a speech synthesizer, select **SPEECH > Windows Voice/Macintosh Voice**. To hear a tone, instead, select **SPEECH > Tones**.
- To optimize playback speed, select **SPEECH > Speed, Faster, or Slower**.
Complementing, reversing and translating sequence

- To create a new window containing the complement of a highlighted portion of sequence, select GOODIES > Reverse Complement.

- To translate a highlighted portion of DNA sequence or reverse translate a highlighted portion of protein sequence, select GOODIES > Translate DNA or GOODIES > Reverse Translate Protein.

- To translate or reverse translate using a genetic code other than the Standard Genetic Code, select GOODIES > Genetic Codes. The genetic code file can be edited using GOODIES > Edit Genetic Code.

- To reverse the order of a selected sequence, select GOODIES>Reverse Sequence
Integration

Overview

SeqBuilder, GeneQuest, PrimerSelect, Protean and MegAlign are able to share much of the same data by means of synchronous updating.

Synchronous updating allows you to work on the same file in any or all of the five Lasergene applications at the same time. Changes made in one application will automatically be applied to the same data in the other shared applications.

Synchronous updating

Synchronous updating allows you to work on the same file in any or all of five Lasergene applications at the same time. Changes made in one application will automatically be applied to the same data in the other shared applications. Use synchronous updating with SeqBuilder, GeneQuest, PrimerSelect, Protean, and MegAlign.

To use synchronous updating, simply open the exact same file in more than one application. Edits that would affect the presentation of that sequence in the other application will appear when you bring the focus to the other application. The following examples demonstrate some of the functionality that you can access using this integration feature.

Opening and modifying a file in two applications

In this example, you will see how you can open the same file in two applications, in this case, MegAlign and SeqBuilder. However, you may use any two of SeqBuilder, MegAlign, PrimerSelect, GeneQuest, and Protean in a manner similar to the following example.

The data for this tutorial can be found in the following location:

- **Windows Vista/Windows 7**: C:\Users\Public\Public Documents\DNASTAR\Lasergene 9 Data\Demo MegAlign
- **Windows XP**: C:\Documents and Settings\All Users\Shared Documents\DNASTAR\Lasergene 9 Data\Demo MegAlign
- **Macintosh OSX**: Hard Drive:Applications:DNASTAR:Lasergene 9 Data:Demo MegAlign
1) Launch MegAlign.

2) Select **FILE > Open**. The Open dialog appears.

3) Select **Calmodulin Alignment.meg** from the **Demo MegAlign** folder.

If, while working on this file, you decided that you needed to edit one of the sequences, you could do so using SeqBuilder, without closing the file. The remaining steps in this example will edit 2 residues in the Black Mold Calmodulin sequence.

4) Highlight the **Black Mold Calmodulin** sequence in the list of Sequence Names.

5) Select **FILE > Send Sequence To > SeqBuilder**. SeqBuilder opens and displays the Black Mold Calmodulin sequence.

6) Modify the sequence by changing the 4th residue from an **S** to a **Q** and the 10th residue from a **V** to an **I**. Here is how this appears in SeqBuilder:
7) Move the focus to MegAlign. Note that the change has been made in the file in MegAlign, as shown below:

<table>
<thead>
<tr>
<th>Taxon</th>
<th>Sequence</th>
</tr>
</thead>
<tbody>
<tr>
<td>Barley Calmod</td>
<td>MADQL TDDQL</td>
</tr>
<tr>
<td>Black Mold Ca</td>
<td>MADQL TEEQI</td>
</tr>
<tr>
<td>Chicken Calnc</td>
<td>MADQL TEEQI</td>
</tr>
</tbody>
</table>

**Note:** Only the sequence has been updated. This may affect the alignment. The alignment is **not** automatically updated. Therefore, after editing, running the alignment again is recommended.

- If you save the changes made in either application using **FILE > Save**, you will save the changes in the original MegAlign document.

- If you save the changes made in either application using **FILE > Save As** and you rename the file or change the file format, the link between the two applications will be broken and synchronous updating will no longer occur.

**Adding a feature to a file in two applications**

In this example, you will see how adding a feature to a sequence in one application will result in adding the same feature to the sequence in another application. This example uses GeneQuest and PrimerSelect. However, you may use any two of SeqBuilder, MegAlign, PrimerSelect, GeneQuest, and Protean for this example.

The data for this tutorial can be found in the following location:

- **Windows Vista/Windows 7:** C:\Users\Public\Public Documents\DNASTAR\Lasergene 9 Data\Demo Data
- **Windows XP:** C:\Documents and Settings\All Users\Shared Documents\DNASTAR\Lasergene 9 Data\Demo Data
- **Macintosh OSX:** Hard Drive:Applications:DNASTAR:Lasergene 9 Data:Demo Data
1) Launch GeneQuest.

2) Select **FILE > Open** to open the project **Nematode R01H10 Assay.dad** From the Demo Data folder.

---

**Note:** You may need to click ![image](image.png) to view the image as it appears below.

---

3) Select **FILE > Send Sequence to > PrimerSelect** to open the file in PrimerSelect. Click on ![image](image.png) to display the Tm plot view.

---

4) Return to GeneQuest and create a new feature:

   a) Click ![image](image.png) and then select a range of bases.

   b) Select **SITES & FEATURES > New Feature**. The Feature Editor appears.

   c) In the Title field, name the new feature **Test feature**.

   d) Click **OK**.
5) Return the focus to PrimerSelect.

6) Select **CONDITIONS > Sequence Positions and Limits**. The Sequence Positions and Limits dialog appears.

7) Click **From Feature Table**. Note that the new feature appears at the bottom of the list.

Note: If you save this sequence file from either application as anything but the original .dad file, the synchronous updating between GeneQuest and PrimerSelect will be lost.
Online Database Searches

Overview

SeqBuilder, GeneQuest, PrimerSelect, Protean, MegAlign, EditSeq and SeqMan Pro allow you to search online databases, such as the National Center for Biotechnology Information's (NCBI's) BLAST and Entrez servers, for sequences or proteins that match all or part of the current file. Perform all online searches from the NET SEARCH menu of these Lasergene applications. Some options vary from application to application, as noted in each section below. Additionally, applications may be able to use different types of results, or use similar results in different manners.

Setting Up Preferences

Before performing an online database search, you must setup Lasergene’s online search preferences. This may be done in any Lasergene application. Once preferences are setup in one Lasergene application, they are shared by all other Lasergene applications.

Note: If multiple Lasergene applications are open while you are setting up the preferences in one, the other applications must be closed and re-launched before the changes will be shared between all of the applications.

To access online preferences, choose an appropriate option from the list below.

Windows

- For SeqMan, select PROJECT > Parameters > Servers.
- For all other Lasergene application, select EDIT > Preferences.

Macintosh

- For SeqMan, select SEQMAN > Preferences > Servers.
- For all other Lasergene applications, select [Application Name] > Preferences. For example, in SeqBuilder, select SEQBUILDERR>Preferences.
Specifying online server addresses

Use the Preferences dialog (or PROJECT>Parameters>Servers in SeqMan) to enter or change your BLAST and Entrez (text) server addresses.

1) Select the Servers tab. The upper portion of the ensuing dialog allows you to store BLAST Server addresses, while the lower portion lets you store Entrez Server addresses.

   • To add a new address to either box, click the associated Add button and type in the address.
   • To delete an address, click the address and click Delete.

2) To set the default server that Lasergene will use when performing a BLAST or text search, click the name of the server in either box and then click Choose.

   Note: To change the default server later, repeat this process but choose a different server in step 2.

3) Click OK to accept the changes or click Restore to reset the default parameters. Click Cancel to leave settings as they were prior to making changes.

Server URLs

• For NCBI’s BLAST 2.0, use http://www.dnastar.com/blast/ncbi-blast.html

Note: For other servers, please consult your system administrator.

Specifying a download folder

Use the Preferences dialog (or PROJECT>Parameters>Internet in SeqMan) to select a default folder for storing downloaded sequences. This is where Lasergene applications will save files downloaded from an online database by default.

1) Select the Internet tab.

2) Click Set Folder. A dialog will appear where you may specify the desired folder. When you are satisfied with your choice, click OK (Win) or Choose (Mac).

   1. Click OK to accept the change or click Restore to reset the default parameter. Click Cancel to leave settings as they were prior to making changes.
Performing a BLAST Search

You can search NCBI’s BLAST databases for a sequence that contains a section that matches the current selected portion of the sequence. You must select a portion of the current sequence before beginning a BLAST search.

1) Select a portion of the current DNA or protein sequence by highlighting it.

2) Select **NET SEARCH > BLAST Selection.** (In GeneQuest, **NET SEARCH> BLAST ORF** is also available). The Blast Query dialog appears. This dialog contains the following options:

- **Server:** BLAST Servers that have been setup using **Preferences** appear here. You may change to a different server by choosing one from the dropdown list, or select **New Server** from the list and then type a new URL into the **Server** field.

- **Programs:** The following programs are available to select, although some servers may not offer all of these programs:
  - **blastn** (searches a nucleotide sequence database with a nucleotide query sequence)
  - **blastp** (searches a protein sequence database with an amino acid query sequence)
  - **blastx** (searches a protein sequence database with the six-frame translation of a nucleotide query sequence)
  - **tblastn** (searches the six-frame translation of a nucleotide sequence database with a protein query sequence).
  - **tblastx** (searches the six-frame translation of a nucleotide sequence database with the six-frame translation of a nucleotide query sequence).

**Note:** When using **BLAST ORF** in GeneQuest, the program is automatically selected for you as **blastp**.

- **Databases:** Select from the databases available on the server by selecting one from the dropdown list.

3) Click **OK**.

After initiating a BLAST search, the BLAST search results window appears. When the server returns results, this window lists any sequences that match the current sequence. You may continue to work with other Lasergene application activities while waiting for BLAST search results, but you cannot launch another BLAST search until you close the current BLAST window.
BLAST search results window

Upon completing a BLAST search, the BLAST results window appears.

The upper pane of the BLAST search results window contains the name of possible matches in order of probability, while the lower pane contains the alignment of the query (upper sequence) to the highlighted database entry (lower sequence).

The following columns are available in upper pane of the BLAST search results window:

- **Score** - The similarity score for the result.
- **Expected** - The expectation value. This corresponds to the **Expect** value displayed in the lower pane of the window.
- **Note**: Detailed information about how "score" and "expectation" are derived is available at [http://www.ncbi.nlm.nih.gov/BLAST](http://www.ncbi.nlm.nih.gov/BLAST). In general, a higher score and lower expectation connote a better match.
- **Query Cov.** - The percentage of the queried sequence that aligns to a match in the database. For example, if you BLAST a range of 596 bases, and 565 of those bases align to a sequence in the database, then the **Query Cov.** value will be 565/596, or 95%. Note that in SeqMan, if a BLAST search is performed from the Project Summary window, then the **Query Cov.** column will also list the contig that contains the matching result.
Note: Query Cov. differs from the Identity value shown in the lower portion of the BLAST window. Identity is the percentage of bases within the alignment that match. For example, if 565 bases align to a sequence in the database, and there are 3 mismatches within the alignment, then the Identity value would be 562/565, or 99.5%.

- **Query Left** - The left end coordinate of the queried sequence that corresponds to the left end coordinate of the matching result (DB Left).
- **Query Right** - The right end coordinate of the queried sequence that corresponds to the right end coordinate of the matching result (DB Right).
- **Identifier** - The sequence identifier for the result.
- **DB Left** - The left end coordinate of the result sequence that corresponds to the left end coordinate of queried sequence (Query Left).
- **DB Right** - The right end coordinate of the result sequence that corresponds to the right end coordinate of queried sequence (Query Right).
- **Description** - The description, from NCBI, of the result sequence.

To sort results in the BLAST search results window, click on a column header to sort the rows by that column.

For additional information on using the BLAST results window, see [Working with search results windows](#).

**Performing a Text Search**

Lasergene provides a graphical interface for constructing Boolean queries of text databases like NCBI’s Entrez database. Search results are returned as a list from which you may select any or all sequences, and then save them or open them as documents in the current application.
1) In any Lasergene application, select **NET SEARCH > New Text Search**. The Entrez Query dialog appears.

![Entrez Query dialog](image1)

- The **Server** field lists the currently selected Entrez server. You may change to a different server by choosing one from the dropdown list provided, or choose a **New Server** and then type a new URL.

- Use the dropdown list in the lower right of the window to choose the database to search. This menu will reflect the available databases on the selected server.

2) Create the search criteria using the fields provided:

![Entrez Query dialog with search criteria](image2)

- Enter the first (or only) criterion into the text box on the left.

- You may change the search field heading from the dropdown list to the right of that text box. The default is **All terms from all searchable fields**, which will search every word of every listing for the query term in the database. The field headings vary depending upon the online database that you are using.
To add a criterion to the query, click the button.

- Choose And, Or, or And Not from the list box on the left of the new row.
- And requires both the first and the second criterion to be present.
- Or will look for matches containing either criterion.
- And Not will search for matches containing the first criterion but not the second.

To remove a criterion, click the button in the row that you want to remove.

3) Once you have defined all of your search criteria, click Search to send the query to the database. When the search is complete, the text search results window appears, showing a list of sequences that match your query.

**Text results search window**

Upon completing a text search, a text results window appears.

This window lists all of the results that match your search criteria. If desired, you can search the results of a text search to reduce the number of matches.

For additional information on using the text search query results window, see Working with Search Results Windows.
Changing a text query

You may modify a text query to obtain different results without having to completely recreate a complex query. To do this, select Net Search> Change This Query. The Entrez Query dialog appears containing the same search criteria that you last used, allowing you to edit as necessary before performing a new search.

Searching text search query results

You may search the results of a text query rather than re-searching the entire text database. This can help you identify the most useful results of a previously-performed query.

To do this, first make sure the text search results window is active by clicking on it. (If you have several text results windows open, select Net Search > Current Results to locate the desired window).

Then, select Net Search>Search These Results to open a text query window. Enter the desired search criteria, and then click Search to search the current results.

When the search is complete, the text search results window will be displayed, showing a list of sequences that match your query.

Working with Search Results Windows

The BLAST and text search results windows permit many similar functions and have common buttons along the top of their windows:

- **Open With:** Use this to open one or more results in the selected Lasergene application. See Opening Results in a Lasergene Application for additional information on using this option.

- **Create Document/Add to Project/Put in Document:** The name of this button varies between Lasergene applications. Use this option to open one or more results in the current application. See Opening Results in a Lasergene Application for additional information on using this option.
Note: In SeqMan, the **Add to Project** button will appear as **Collect Features** if the sequence you selected to BLAST is not already associated with trace or flowgram data. For more information, see *Collecting Features from a BLAST Search*

- **Launch browser**: Use this option to open one or more results in your default web browser. See Viewing results in a web browser for additional information on using this option.

- **Batch Save**: Use this option to save a group of results as sequence files. See Saving multiple results for additional information on using this option.

- **Print**: Click this option to print one or more results. See Printing BLAST Search Results or Printing Text Search Results for additional information on using this option.

## Selecting one or more results

You can select one or more results from a results window by using any of the following methods. Once selected, you may then open, view, save, or print that selection of results.

- Click a result to select only that result.

- Check each result by clicking to the left of the result in the results window. Use this method to select a group of consecutive or non-consecutive results. This method has an advantage over using **Ctrl+click** as you will not lose selected results if you forget to hold down the button when choosing a result.

- Press and hold **Ctrl/Cmd** while clicking each desired result on the results window. Use this method to select a group of consecutive or non-consecutive results.

- Click a result, and then press and hold **Shift** while clicking another result to select those two results and all of the intervening results.
Opening results in a Lasergene application

You can view results by opening one or more in a Lasergene application. To do this, first select one or more results from your search results window. Then, do one of the following:

- To open the results in a different Lasergene application than the current one, select a Lasergene application from the list box above the words **Open With**.

- To open the results in the current Lasergene application, click **Create Document/Add to Project/Put in Document**. In the resulting dialog, select one of the following options from the **Save** field:
  - **Top** opens the specified number of matches, starting with the first sequence on the list. Specify a number in the text box (default is 10).
  - **Next** opens the specified number of sequences, starting with the first one currently highlighted. Specify a number in the text box (default is 10).
  - **Checked** opens sequences with a checkmark beside them.
  - **Selected** opens only highlighted sequences.
  - **All** opens all sequences.

To save the file(s) in a location other than the default directory, click the **Set Location** button. Finally, click **OK** again to save the sequence files and either add them to the current project or open them in a different Lasergene application.

Viewing results in a web browser

You can view detailed information about your search results using a web browser. To do so, first select one or more results from the search results window. Then, click the **Launch Browser** button. Alternately, you may select **Net Search>Open with Web Browser**.

Each selected match will be displayed in a separate browser window.

**Note:** Popup blocking software may prevent Lasergene from opening multiple web browser windows simultaneously. Check the documentation for your popup blocking software for additional information.
Saving multiple search results

You may save multiple search results as sequence files from the search results window. To do this, first select one or more results from the search results window. Then, click the Batch Save button. In the resulting dialog, select one of the following options from the Save field:

- **Top** opens the specified number of matches, starting with the first sequence on the list. Specify a number in the text box (default is 10).
- **Next** opens the specified number of sequences, starting with the first one currently highlighted. Specify a number in the text box (default is 10).
- **Checked** opens sequences with a checkmark beside them.
- **Selected** opens only highlighted sequences.
- **All** opens all sequences.

To save the file(s) in a location other than the default directory, click the Set Location button. Finally, click OK again to save the sequence files to the specified directory.

Printing BLAST search results

To print BLAST search results, first select one or more results from the search results window. Then, click the Print button. In the resulting dialog, select one of the following options from the Print field:

- **Top** prints the specified number of matches, starting with the first sequence on the list. Specify a number in the text box (default is 10).
- **Next** prints the specified number of sequences, starting with the first one currently highlighted. Specify a number in the text box (default is 10).
- **Checked** prints sequences with a checkmark beside them.
- **Selected** prints only highlighted sequences.
- **All** prints all sequences.

Click Print to proceed with printing using the standard Print dialog for your computer’s operating system.
Printing text search results

To print one or more results from a text search results window, first select one or more results. Then, click the Print button. The standard Print dialog for your computer’s operating system will be displayed, allowing you to proceed with printing your selected results.

Copying results

Selected results may be copied to the clipboard from the BLAST or text search results window by using EDIT>Copy.

When you copy results from the upper pane of the BLAST or text search results window, the information includes identifier information and a description for each selected result.

You may also copy text from the bottom pane of the window from a BLAST search results window. In this case, the text you select is exactly what will be copied.

Note: When pasting data into a word processing application, choose a mono-spaced font such as Courier so that the alignments display correctly.

Saving search results as text files

To save your BLAST or text search results as a text file:

1) Make the results window the active window.
2) Select FILE > Save BLAST Report (SeqMan Pro only) or FILE > Save As (other Lasergene applications).
3) Find a location to save the document using the Save In menu.
4) Enter a new name in the File Name window (the default name is "Untitled").
5) Click Save. Lasergene will automatically add the correct text file extension (*.txt) when saving the file.
Copyright Information

All rights reserved. Reproduction, adaptation, or translation without prior written permission is prohibited, except as allowed under the copyright laws or with the permission of DNASTAR, Inc.


Trademark Information:


Microsoft®, Windows® and Windows Vista® are registered trademarks of Microsoft Corp. Intel® and Pentium® are registered trademarks of Intel Corporation. Macintosh®, Mac OS® and BootCamp® are registered trademarks of Apple Computers, Inc. Parallels Desktop® is a registered trademark of Parallels, Inc. Adobe® Illustrator® and Adobe® PostScript® are registered trademarks of Adobe Systems, Inc. Linux® is a registered trademark of Linux Torvalds. Ubuntu® is a registered trademark of the Ubuntu Project. CentOS compliments of the Community Enterprise Operating System.

Affymetrix®, NetAffx™, Expression Console™, and Affymetrix GeneChip-compatible™ are trademarks or registered trademarks of Affymetrix, Inc. NimbleGen™ is a trademark of NimbleGen Systems, Inc. Illumina® and BeadStudio™ are trademarks or registered trademarks of Illumina, Inc. 454™ is a trademark of the Roche Diagnostics Corporation. Agilent® is a registered trademark of Agilent. MacVector® and GCG® are registered trademarks of Accelrys Inc. Sequencher® is a registered trademark of Gene Codes Corporation. SOLiD™ is a trademark of Applied Biosystems. pGEM is a registered trademark of Promega Corporation. GenePix® is a registered trademark of MDS Analytical Technologies.™

The following products are registered trademarks, trademarks or copyrighted materials of Life Technologies™: Ion Torrent™, pENTR, Lumio, DEST, pcDNA, pDONR, BioEase, GeneBLAzer, BLOCK-iT, Gus, Xpress, Zeocin, pCR, CAT, HisMax. Life Technologies Corporation is the assignee of numerous patents related to aspects of GateWay® and TOPO® cloning technologies. Use of GateWay® and TOPO® vectors and reagents to perform in vitro or in vivo experiments that are simulated using DNASTAR’s Lasergene software may require a license from Life Technologies Corporation. Contact Life Technologies Corporation at (760)
603-7200 in the United States or via their website to obtain more information regarding their requirements in this regard.

DNASTAR is authorized by Geneva Bioinformatics (GeneBio) S.A. to incorporate PROSITE® data into Lasergene. PROSITE® is a registered trademark of the Swiss Institute of Bioinformatics (SIB) and GeneBio has been granted exclusive rights by the SIB for the licensing of PROSITE. Access to PROSITE® via Lasergene requires a user license which can be obtained by contacting GeneBio at sib-db@genebio.com or info@genebio.com.


BioJava (©2000-2011, BioJava and contributing authors; all rights reserved) is licensed under the LGPL Version 2.1. Java Native Access (JNA, © 2006-2011, Timothy Wall, Wayne Meissner and contributing authors; all rights reserved) is licensed under the LGPL Version 2.1. Java OpenGL (JOGL, © 2003-2007, Sun Microsystems, Inc.; all rights reserved) is licensed under the BSD license. KSDSSP courtesy of the University of California-San Francisco. Yale Morph Server courtesy of Mark Gerstein and Yale University. The Protein Data Bank courtesy of the Research Collaboratory for Structural Bioinformatics (RCSB).

The license management portion of this Licensed Technology is based on SentinelLM®, (© 1989-2011, SafeNet, Inc.; all rights reserved). Sentinel® is a registered trademark of SafeNet, Inc. KeyServer®, KeyAccess®, and KeyVerify® are registered trademarks of Sassafras Software Inc. VMware® is a registered trademark of VMware, Inc. Some DNASTAR applications use the Eclipse platform, supplied by the Eclipse Foundation under an Eclipse Public License (EPL).

All other copyrights, trademarks, and registered trademarks are the property of their respective owners. DNASTAR, Inc. does not encourage the infringement of any patents owned by any other party.

Disclaimer & Liability: DNASTAR, Inc. makes no warranties, expressed or implied, including without limitation the implied warranties of merchantability and fitness for a particular purpose, regarding the software. DNASTAR does not warrant, guaranty, or make any representation regarding the use or the results of the use of the software in terms of correctness, accuracy, reliability, up-to-date status, or otherwise. The entire risk as to the results and performance of the software is assumed by you. The exclusion of implied warranties is not permitted by some states. The above exclusion may not apply to you.

In no event will DNASTAR, Inc. and their directors, officers, employees, or agents (collectively DNASTAR) be liable to the licensee of ArrayStar for any consequential, incidental or indirect damages (including damages for loss of business profits, business interruption, loss of business information and the like) arising out of the use of, or the inability to use the software even if DNASTAR, Inc. has been advised of the possibility of such damages. Because some states do
not allow the exclusion or limitation of liability for consequential or incidental damages, the above limitations may not apply to you.

DNASTAR, Inc. reserves the right to revise this publication and to make changes to it from time to time without obligation of DNASTAR, Inc. to notify any person or organization of such revision or changes. The screen and other illustrations in this publication are meant to be representative of those that appear on your monitor or printer.